12. Considérations IANA
[IMAP-OBSOLETE] Crispin, M., "Internet Message Access Protocol - Obsolete Syntax", RFC 2062, December 1996.
[IMAP2] Crispin, M., "Interactive Mail Access Protocol - Version 2", RFC 1176, August 1990.
[RFC-822] Crocker, D., "Standard for the Format of ARPA Internet Text Messages", STD 11, RFC 822, August 1982.
[RFC-821] Postel, J., "Simple Mail Transfer Protocol", STD 10, RFC 821, August 1982.
B. Modifications par rapport à la RFC 2060
-
Clarification du sens des identifiants uniques (UID) et de leur sémantique.
-
Correction de la description de SELECT, en clarifiant que UIDVALIDITY est nécessaire dans les réponses SELECT et EXAMINE.
-
Ajout d'un exemple de recherche en échec.
-
Correction de store-att-flags : "#flag" doit être "1#flag".
-
Règles search et section rendues plus claires.
-
Correction de l'exemple de STORE.
-
Correction de la faute de frappe "BASE645".
-
Suppression d'une parenthèse fermante excédentaire dans l'exemple d'un message à deux parties avec texte et pièce jointe BASE64.
RFC 3501 IMAPv4 March 2003
-
Suppression de la réponse "MAILBOX" obsolète de mailbox-data.
-
Suppression du faux "<" de la règle mailbox-data.
-
Ajout de CRLF à continue-req.
-
Exclusion explicite de "]" de l'atome resp-text-code.
-
Clarification du fait que les clients et serveurs doivent suivre strictement la syntaxe du protocole.
-
Dans la section 5.2, insistance sur le fait qu'EXISTS ne peut pas être utilisé pour réduire la taille d'une boîte aux lettres.
-
Ajout de NEWNAME aux codes de réponse (resp-text-code).
-
Clarification du fait que c'est la chaîne vide, et non NIL, qui est utilisée comme argument de LIST.
-
Clarification du fait qu'un séparateur de hiérarchie NIL peut être renvoyé comme argument de nom de boîte aux lettres si l'espace de noms est plat.
-
Clarification du fait que les guillemets RFC-2822 sont supprimés d' addr-mailbox et addr-name.
-
Mise à jour de la référence UTF-7.
-
Correction de l'exemple de la section 6.3.11.
-
Clarification du fait que les UID inexistants sont ignorés.
-
Mise à jour de la référence DISPOSITION.
-
Extension du diagramme d'état.
-
Clarification du fait que les réponses de récupération partielles ne sont renvoyées que dans les cas suivants.