Zum Hauptinhalt springen

12. IANA-Überlegungen (IANA Considerations)

and IMAP2bis", RFC 1732, December 1994.

[IMAP-OBSOLETE] Crispin, M., "Internet Message Access Protocol - Obsolete Syntax", RFC 2062, December 1996.

[IMAP2] Crispin, M., "Interactive Mail Access Protocol - Version 2", RFC 1176, August 1990.

[RFC-822] Crocker, D., "Standard for the Format of ARPA Internet Text Messages", STD 11, RFC 822, August 1982.

[RFC-821] Postel, J., "Simple Mail Transfer Protocol", STD 10, RFC 821, August 1982.

B. Änderungen gegenüber RFC 2060 (Changes from RFC 2060)

  1. Klärung der Beschreibung von eindeutigen Bezeichnern (unique identifiers) und deren Semantik.

  2. Korrektur der SELECT-Beschreibung, um klarzustellen, dass UIDVALIDITY in den SELECT- und EXAMINE-Antworten erforderlich ist.

  3. Ein Beispiel für eine fehlgeschlagene Suche (search) hinzugefügt.

  4. Korrektur von store-att-flags: „#flag" sollte „1#flag" lauten.

  5. Die Regeln für search und section klarer gefasst.

  6. Das STORE-Beispiel korrigiert.

  7. Den Rechtschreibfehler „BASE645" korrigiert.

  8. Eine überflüssige schließende Klammer im Beispiel einer zweiteiligen Nachricht mit text und BASE64-Anhang entfernt.

RFC 3501 IMAPv4 March 2003

  1. Die veraltete „MAILBOX"-Antwort aus mailbox-data entfernt.

  2. Ein irreführendes "<" in der Regel für mailbox-data wurde entfernt.

  3. CRLF zu continue-req hinzugefügt.

  4. „]" explizit aus dem atom in resp-text-code ausgeschlossen.

  5. Klargestellt, dass Clients und Server strikter an die Protokollsyntax gebunden sein sollten.

  6. In 5.2 hervorgehoben, dass EXISTS nicht verwendet werden kann, um eine Mailbox zu verkleinern.

  7. NEWNAME zu resp-text-code hinzugefügt.

  8. Klargestellt, dass die leere Zeichenkette und nicht NIL als Argument für LIST verwendet wird.

  9. Klargestellt, dass NIL als Hierarchie-Trennzeichen für das Argument des leeren Mailbox-Namens zurückgegeben werden kann, wenn der Mailbox-Namensraum flach ist.

  10. Klargestellt, dass bei addr-mailbox und addr-name das RFC-2822- Quoting entfernt wird.

  11. Den UTF-7-Verweis aktualisiert.

  12. Das Beispiel in 6.3.11 korrigiert.

  13. Klargestellt, dass nicht existierende UIDs ignoriert werden.

  14. Den DISPOSITION-Verweis aktualisiert.

  15. Das Zustandsdiagramm erweitert.

  16. Klargestellt, dass partielle fetch-Antworten nur in