12. IANA Considerations
[IMAP-OBSOLETE] Crispin, M., "Internet Message Access Protocol - Obsolete Syntax", RFC 2062, December 1996.
[IMAP2] Crispin, M., "Interactive Mail Access Protocol - Version 2", RFC 1176, August 1990.
[RFC-822] Crocker, D., "Standard for the Format of ARPA Internet Text Messages", STD 11, RFC 822, August 1982.
[RFC-821] Postel, J., "Simple Mail Transfer Protocol", STD 10, RFC 821, August 1982.
B. Changes from RFC 2060
-
一意識別子およびその意味論の記述を明確化した.
-
SELECT の記述を修正し, UIDVALIDITY が SELECT および EXAMINE レスポンスで 必要であることを明確化した.
-
失敗する検索の例を追加した.
-
store-att-flags を修正: "#flag" は "1#flag" でなければならない.
-
search および section の規則をより明確にした.
-
STORE の例を修正した.
-
"BASE645" の誤字を修正した.
-
テキストと BASE64 添付ファイルを持つ 2 パートメッセージの例から, 余分な閉じ括弧を削除した.
RFC 3501 IMAPv4 March 2003
-
mailbox-data から廃止された "MAILBOX" レスポンスを削除した.
-
mailbox-data の規則から偽の "<" を削除した.
-
continue-req に CRLF を追加した.
-
resp-text-code の atom から明示的に "]" を除外した.
-
クライアントとサーバーはプロトコル構文に厳密に従うべきであることを 明確化した.
-
5.2 において, EXISTS を使用してメールボックスを縮小できないことを 強調した.
-
resp-text-code に NEWNAME を追加した.
-
引数として LIST に使用されるのは NIL ではなく空文字列であることを 明確化した.
-
メールボックス名前空間がフラットな場合, 空文字列のメールボックス名 引数に対して階層区切り文字として NIL が返され得ることを明確化した.
-
addr-mailbox および addr-name からは RFC-2822 の引用が除去されることを 明確化した.
-
UTF-7 の参照を更新した.
-
6.3.11 の例を修正した.
-
存在しない UID は無視されることを明確化した.
-
DISPOSITION の参照を更新した.
-
状態図を拡張した.
-
部分フェッチレスポンスは以下でのみ返されることを明確化した.