Appendix A. References
-
UIDNEXT レスポンスコードを追加した. UIDVALIDITY の定義の参照を修正した.
-
"can" と "MAY" のさらなる明確化.
-
RFC-2119 を参照した.
-
修正 UTF-7 において余分なシフトは許可されないことを明確化した.
-
修正 UTF-7 には暗黙のシフトが存在しないことを明確化した.
RFC 3501 IMAPv4 March 2003
-
メールボックス名における "INBOX" は, 文字列として与えられた場合でも常に INBOX であることを明確化した.
-
media-basic 文法規則の欠落していた開き括弧を追加した.
-
mailbox-data の属性構文を修正した.
-
EXAMINE レスポンスに UIDNEXT を追加した.
-
SELECT および EXAMINE における UNSEEN, PERMANENTFLAGS, UIDVALIDITY, UIDNEXT レスポンスを明確化した. これらは現在必須であるが, 古いバージョンでは必須ではなかった.
-
参照を RFC 番号で更新した.
-
text-mime2 をフラッシュした.
-
修正 UTF-7 名は大文字と小文字を区別しなければならず, その慣例に違反することは避けるべきであることを明確化した.
-
UID FETCH の例を修正した.
-
UID FETCH, UID STORE, UID SEARCH とタグなし EXPUNGE レスポンスの違いを明確化した.
-
"convention" (慣例) という語の使用を明確化した.
-
コマンドは完全に受信されるまで「実行中」ではない (具体的には, コマンド継続の交渉中はコマンドは「実行中」ではない) ことを明確化した.
-
エンベロープのデフォルト設定を明確化した.
-
SP は 1 つのスペース文字のみを意味することを明確化した.
-
LIST レスポンスにおける不適切な状態を禁止した.
-
メッセージの ENVELOPE, INTERNALDATE, RFC822*, BODY*, UID は静的であることを明確化した.
-
BADCHARSET レスポンスコードを追加した.
-
正式な構文を [ABNF] の慣例に更新した.
-
CREATE の意味論における末尾の階層区切り文字を明確化した.
-
「空行」は [RFC-2822] の区切り用空行であることを明確化した.
RFC 3501 IMAPv4 March 2003
-
RENAME は, コマンドが完了するために必要に応じて階層も作成すべきである (SHOULD) ことを明確化した.
-
disposition が存在する場合に言語を必須としないように body-ext-mpart を修正した.
-
RFC822.HEADER レスポンスを明確化した.
-
検索における charset astring の後の欠落していたスペースを修正した.
-
resp-text-code の BADCHARSET に対する欠落していた引用符を修正した.
-
ALL, FAST, FULL は他のいかなるデータ項目の出現も排除することを明確化した.
-
LIST における参照引数の意味論を明確化した.
-
SEARCH HEADER X-FOO に対する空文字列は, ヘッダーのテキストに関係なく, フィールド名が X-FOO であるヘッダー行を持つ任意のメッセージを意味することを明確化した.
-
将来の UTF-8 としての使用のために 8 ビットのメールボックス名を特に予約した.
-
クライアントが PERMANENTFLAGS リストにないフラグを格納することはエラーではない. ただし, サーバーは変更を無視するか, セッション内のみで変更を行う.
-
余分なシフトに関する記述を修正/明確化した.
-
「変更」セクションの誤植を修正した.
-
STATUS を選択されたメールボックス内の新着メッセージの確認に使用してはならないことを明確化した.
-
"%" ワイルドカードを用いた LSUB の挙動を明確化した.
-
セクション 7.5 の AUTHORIZATION を AUTHENTICATE に変更した.
-
マルチパートボディタイプの記述を明確化した.
-
STORE FLAGS は \Recent に影響しないことを明確化した.
-
タイムゾーンの記述の "west" を "east" に変更した.