Zum Hauptinhalt springen

Anhang A. Referenzen (Appendix A. References)

  1. UIDNEXT-Antwortcode hinzugefügt. Verweis auf UIDVALIDITY-Definition korrigiert.

  2. Weitere Klärung von „can" gegenüber „MAY".

  3. Verweis auf RFC-2119.

  4. Klargestellt, dass überflüssige Shifts in modifiziertem UTF-7 nicht zulässig sind.

  5. Klargestellt, dass es in modifiziertem UTF-7 keine impliziten Shifts gibt.

RFC 3501 IMAPv4 March 2003

  1. Klargestellt, dass „INBOX" in einem Mailbox-Namen immer INBOX ist, selbst wenn sie als Zeichenkette angegeben wird.

  2. Fehlende öffnende Klammer in der media-basic-Grammatikregel hinzugefügt.

  3. Attribut-Syntax in mailbox-data korrigiert.

  4. UIDNEXT zu den EXAMINE-Antworten hinzugefügt.

  5. UNSEEN-, PERMANENTFLAGS-, UIDVALIDITY- und UIDNEXT-Antworten in SELECT und EXAMINE geklärt. Sie sind nun erforderlich, waren es in älteren Versionen jedoch nicht.

  6. Verweise mit RFC-Nummern aktualisiert.

  7. text-mime2 bereinigt.

  8. Klargestellt, dass modifizierte UTF-7-Namen groß-/kleinschreibungssensitiv sein müssen und dass die Verletzung der Konvention vermieden werden sollte.

  9. UID FETCH-Beispiel korrigiert.

  10. UID FETCH, UID STORE und UID SEARCH gegenüber nicht getaggten EXPUNGE-Antworten geklärt.

  11. Die Verwendung des Wortes „convention" geklärt.

  12. Klargestellt, dass ein Befehl erst dann „in progress" ist, wenn er vollständig empfangen wurde (insbesondere, dass ein Befehl während der Aushandlung der Befehlsfortsetzung nicht „in progress" ist).

  13. Umschlag-Vorbesetzung (envelope defaulting) geklärt.

  14. Klargestellt, dass SP genau ein und nur ein Leerzeichen bedeutet.

  15. Unzulässige Zustände in der LIST-Antwort verboten.

  16. Klargestellt, dass ENVELOPE, INTERNALDATE, RFC822*, BODY* und UID für eine Nachricht statisch sind.

  17. BADCHARSET-Antwortcode hinzugefügt.

  18. Formale Syntax an [ABNF]-Konventionen angepasst.

  19. Nachgestelltes Hierarchie-Trennzeichen in der CREATE-Semantik geklärt.

  20. Klargestellt, dass die „leere Zeile" die [RFC-2822] begrenzende leere Zeile ist.

RFC 3501 IMAPv4 March 2003

  1. Klargestellt, dass RENAME auch eine Hierarchie nach Bedarf erstellen sollte, damit der Befehl abgeschlossen werden kann.

  2. body-ext-mpart korrigiert, damit language nicht erforderlich ist, wenn disposition vorhanden ist.

  3. Die RFC822.HEADER-Antwort geklärt.

  4. Fehlendes Leerzeichen nach charset astring in search korrigiert.

  5. Fehlendes Anführungszeichen für BADCHARSET in resp-text-code korrigiert.

  6. Klargestellt, dass ALL, FAST und FULL das Auftreten beliebiger anderer Datenelemente ausschließen.

  7. Semantik des reference-Arguments in LIST geklärt.

  8. Klargestellt, dass eine Null-Zeichenkette für SEARCH HEADER X-FOO jede Nachricht mit einer Header-Zeile mit dem Feldnamen X-FOO bedeutet, unabhängig vom Text des Headers.

  9. 8-Bit-Mailbox-Namen ausdrücklich für zukünftige Verwendung als UTF-8 reserviert.

  10. Es ist kein Fehler, wenn der Client ein Flag speichert, das nicht in der PERMANENTFLAGS-Liste ist; der Server wird die Änderung jedoch entweder ignorieren oder nur in der Sitzung vornehmen.

  11. Text bezüglich überflüssiger Shifts korrigiert/geklärt.

  12. Typografische Fehler im Abschnitt „Changes" korrigiert.

  13. Klargestellt, dass STATUS nicht verwendet werden darf, um auf neue Nachrichten in der ausgewählten Mailbox zu prüfen.

  14. LSUB-Verhalten mit „%"-Platzhalter geklärt.

  15. AUTHORIZATION in Abschnitt 7.5 zu AUTHENTICATE geändert.

  16. Beschreibung des mehrteiligen Body-Typs (multipart body type) geklärt.

  17. Klargestellt, dass STORE FLAGS \Recent nicht beeinflusst.

  18. „west" zu „east" in der Beschreibung der Zeitzone geändert.