2. Aperçu des fonctionnalités SIP (Overview of SIP Functionality)
2 Aperçu des fonctionnalités SIP (Overview of SIP Functionality)
SIP est un protocole de contrôle de niveau application capable d'établir, de modifier et de terminer des sessions multimédias (conférences), telles que des appels de téléphonie Internet. SIP peut également inviter des participants à des conférences existantes, qui utilisent déjà le multicast. Les médias peuvent être ajoutés (et supprimés) à une session existante. SIP prend en charge de manière transparente le mappage de noms et les services de redirection, ce qui permet la mobilité personnelle [27]. C'est-à-dire, un utilisateur peut maintenir un identifiant unique visible de l'extérieur, indépendamment de son emplacement sur le réseau.
SIP prend en charge les cinq aspects suivants de l'établissement et de la fin de communications multimédias :
User location (Localisation de l'utilisateur) : détermination des systèmes terminaux à utiliser pour la communication ;
User availability (Disponibilité de l'utilisateur) : détermination de la volonté de l'appelé de communiquer ;
User capabilities (Capacités de l'utilisateur) : détermination des médias et paramètres de média à utiliser ;
Session setup (Établissement de session) : « sonnerie (ringing) », établissement des paramètres de session des deux côtés, appelant et appelé ;
Session management (Gestion de session) : transfert et fin de session, modification des paramètres de session et invocation de services.
SIP n'est pas un système de communication intégré verticalement. SIP est un composant qui peut être utilisé avec d'autres protocoles IETF pour construire une architecture multimédia complète. Typiquement, une telle architecture inclut des protocoles tels que le Real-time Transport Protocol (RTP) (RFC 1889 [28]) pour fournir le transfert de données en temps réel et le retour d'information sur la QoS, le Real-Time Streaming Protocol (RTSP) (RFC 2326 [29]) pour contrôler la diffusion de médias en flux, le Media Gateway Control Protocol (MEGACO) (RFC 3015 [30]) pour contrôler les passerelles vers le réseau téléphonique public commuté (Public Switched Telephone Network, PSTN), et le Session Description Protocol (SDP) (RFC 2327 [1]) pour décrire les sessions multimédias. Par conséquent, SIP doit être utilisé en conjonction avec d'autres protocoles pour fournir un service complet à l'utilisateur. Cependant, son fonctionnement de base et son comportement ne dépendent d'aucun de ces protocoles.
SIP ne fournit pas de services ; à la place, il fournit des primitives qui peuvent être utilisées pour implémenter différents services. Par exemple, SIP peut identifier un utilisateur et lui livrer un objet opaque à son emplacement actuel. En utilisant cette primitive pour livrer une description de session décrite par SDP, les extrémités peuvent s'entendre sur les paramètres de session. En utilisant la même primitive pour livrer une photo de l'appelant avec une description de session, un service « caller ID » peut être facilement implémenté. Comme cet exemple le montre, une seule primitive est généralement utilisée pour fournir plusieurs services différents.
SIP ne fournit pas de services de contrôle de conférence tels que le contrôle de parole (floor control) ou le vote, et ne spécifie pas comment gérer une conférence. SIP peut être utilisé pour démarrer une session qui utilise d'autres protocoles de contrôle de conférence. Les messages SIP et la session qu'ils établissent peuvent traverser des réseaux très différents, de sorte que SIP ne peut pas et ne fournit aucune fonction de réservation de ressources réseau d'aucun type.
Compte tenu de la nature des services fournis, la sécurité est particulièrement importante. Par conséquent, SIP fournit un ensemble de services de sécurité incluant la prévention du déni de service (denial-of-service), l'authentification (user-to-user et proxy-to-user), la protection de l'intégrité et des services de chiffrement et de confidentialité.
SIP fonctionne à la fois avec IPv4 et IPv6.