2. Panoramica delle funzionalità SIP (Overview of SIP Functionality)
2 Panoramica delle funzionalità SIP (Overview of SIP Functionality)
SIP è un protocollo di controllo di livello applicazione in grado di stabilire, modificare e terminare session multimediali (conferenze), come le chiamate di telefonia Internet. SIP può anche invitare partecipanti a conferenze esistenti che già utilizzano il multicast. I media possono essere aggiunti (e rimossi) a una session esistente. SIP supporta in modo trasparente la mappatura dei nomi e i servizi di reindirizzamento, consentendo la mobilità personale [27]. Cioè, un utente può mantenere un identificatore unico visibile dall'esterno, indipendentemente dalla sua posizione nella rete.
SIP supporta i seguenti cinque aspetti dell'instaurazione e della fine delle comunicazioni multimediali:
User location (Posizione dell'utente): determinazione dei sistemi terminali da utilizzare per la comunicazione;
User availability (Disponibilità dell'utente): determinazione della volontà del chiamato di comunicare;
User capabilities (Capacità dell'utente): determinazione dei media e dei parametri dei media da utilizzare;
Session setup (Instaurazione di session): "suoneria (ringing)", instaurazione dei parametri di session di entrambi i lati, chiamante e chiamato;
Session management (Gestione di session): trasferimento e fine di session, modifica dei parametri di session e invocazione di servizi.
SIP non è un sistema di comunicazione integrato verticalmente. SIP è un componente che può essere utilizzato con altri protocolli IETF per costruire un'architettura multimediale completa. Tipicamente, tale architettura include protocolli come il Real-time Transport Protocol (RTP) (RFC 1889 [28]) per fornire il trasferimento di dati in tempo reale e il feedback sulla QoS, il Real-Time Streaming Protocol (RTSP) (RFC 2326 [29]) per controllare il flusso di media in streaming, il Media Gateway Control Protocol (MEGACO) (RFC 3015 [30]) per controllare i gateway verso la rete telefonica pubblica commutata (Public Switched Telephone Network, PSTN), e il Session Description Protocol (SDP) (RFC 2327 [1]) per descrivere le session multimediali. Pertanto, SIP deve essere utilizzato in concomitanza con altri protocolli per fornire un servizio completo all'utente. Tuttavia, il suo funzionamento e comportamento di base non dipendono da nessuno di questi protocolli.
SIP non fornisce servizi; invece, fornisce primitive che possono essere utilizzate per implementare diversi servizi. Per esempio, SIP può identificare un utente e consegnargli un oggetto opaco alla sua posizione attuale. Utilizzando questa primitiva per consegnare una descrizione di session descritta da SDP, gli endpoint possono concordare i parametri di session. Utilizzando la stessa primitiva per consegnare una foto del chiamante con una descrizione di session, un servizio "caller ID" può essere facilmente implementato. Come mostra questo esempio, una singola primitiva è generalmente utilizzata per fornire diversi servizi.
SIP non fornisce servizi di controllo di conferenza come il controllo della parola (floor control) o il voto, e non specifica come gestire una conferenza. SIP può essere utilizzato per avviare una session che utilizza altri protocolli di controllo di conferenza. I messaggi SIP e la session che essi stabiliscono possono attraversare reti molto diverse, così SIP non può e non fornisce alcuna funzione di prenotazione di risorse di rete di alcun tipo.
Data la natura dei servizi forniti, la sicurezza è particolarmente importante. Pertanto, SIP fornisce un insieme di servizi di sicurezza che includono la prevenzione del denial-of-service, l'autenticazione (user-to-user e proxy-to-user), la protezione dell'integrità e servizi di crittografia e privacy.
SIP funziona sia con IPv4 che con IPv6.