メインコンテンツまでスキップ

2. Overview of SIP Functionality

2 Overview of SIP Functionality

SIP は, インターネット電話通話などのマルチメディアセッション (会議) を確立, 変更, 終了できるアプリケーション層制御プロトコルです. SIP は, マルチキャスト会議などの既存のセッションにも参加者を招待できます. メディアを既存のセッションへ追加 (および削除) することもできます. SIP は, 氏名マッピングおよびリダイレクションサービスを透過的にサポートし, これによりパーソナルモビリティ [27] をサポートします — ユーザは, ネットワーク上の位置に関係なく, 単一の外部から可視な識別子を維持できます.

SIP は, マルチメディア通信の確立と終了の 5 つの側面をサポートします.

  ユーザの位置: 通信に使用するエンドシステムの決定.

ユーザの可用性: 呼び出される側が通信を行う意思があるかの決定.

ユーザの能力: 使用されるメディアおよびメディアパラメータの決定.

セッション設定: 「呼び出し音」, 呼び出される側と呼び出す側の両方でのセッションパラメータの確立.

セッション管理: セッションの転送および終了, セッションパラメータの変更, およびサービスの起動を含みます.

SIP は垂直統合された通信システムではありません. むしろ SIP は, 完全なマルチメディアアーキテクチャを構築するために他の IETF プロトコルと共に使用できるコンポーネントです. 典型的には, これらのアーキテクチャには, リアルタイムデータの転送および QoS フィードバックを提供する Real-time Transport Protocol (RTP) (RFC 1889 [28]), ストリーミングメディアの配信を制御する Real-Time Streaming Protocol (RTSP) (RFC 2326 [29]), 公衆交換電話網 (PSTN) へのゲートウェイを制御する Media Gateway Control Protocol (MEGACO) (RFC 3015 [30]), およびマルチメディアセッションを記述する Session Description Protocol (SDP) (RFC 2327 [1]) などのプロトコルが含まれます. したがって, ユーザに完全なサービスを提供するためには, SIP は他のプロトコルと併用する必要があります. ただし, SIP の基本機能と動作は, これらのプロトコルのいずれにも依存しません.

SIP はサービスを提供しません. むしろ, SIP は異なるサービスを実装するために使用できるプリミティブを提供します. たとえば, SIP はユーザを位置特定し, 不透明なオブジェクトをその現在の位置へ配信できます. このプリミティブを使用して, たとえば SDP で記述されたセッション記述を配信すれば, エンドポイントはセッションのパラメータに合意できます. 同じプリミティブを使用して, 発信者の写真とセッション記述の両方を配信すれば, 「発信者番号表示」サービスを簡単に実装できます. この例が示すように, 単一のプリミティブは典型的にはいくつかの異なるサービスを提供するために使用されます.

SIP は, フロア制御や投票などの会議制御サービスを提供せず, 会議をどのように管理すべきかを規定しません. SIP は, いくつかの他の会議制御プロトコルを使用するセッションを開始するために使用できます. SIP メッセージおよびそれらが確立するセッションは完全に異なるネットワークを通過できるため, SIP はいかなる種類のネットワークリソース予約能力も提供しません (また, 提供できません).

提供されるサービスの性質により, セキュリティが特に重要になります. そのために, SIP は, サービス拒否防止, 認証 (ユーザ間およびプロキシからユーザへ), 完全性保護, および暗号化とプライバシーサービスを含む一連のセキュリティサービスを提供します.

SIP は IPv4 と IPv6 の両方で動作します.