メインコンテンツまでスキップ

6. Definitions

6 Definitions

以下の用語は, SIP において特別な意味を持ちます.

  Address-of-Record (AOR): アドレス・オブ・レコードは, ユーザが利用可能な別の URI へその URI をマッピングできるロケーションサービスを持つドメインを指す SIP または SIPS URI です. 通常, ロケーションサービスは登録によって投入されます. AOR はしばしばユーザの "公開アドレス" と考えられます.

  Back-to-Back User Agent: バック・ツー・バック・ユーザエージェント (B2BUA) は, リクエストを受信し, ユーザエージェントサーバ (UAS) としてそれを処理する論理エンティティです. リクエストにどう応答すべきかを決定するため, ユーザエージェントクライアント (UAC) として動作し, リクエストを生成します. プロキシサーバとは異なり, ダイアログの状態を保持し, 確立したダイアログ上で送信されるすべてのリクエストに参加しなければなりません. これは UAC と UAS の連結であるため, その動作について明示的な定義は不要です.

  Call: 呼 (call) とは, ピア間の何らかの通信を指す非公式な用語で, 通常はマルチメディア会話を目的として設定されます.

  Call Leg: ダイアログの別名 [31]. 本仕様ではもはや使用されません.

  Call Stateful: プロキシが, 開始の INVITE から終端の BYE リクエストまでダイアログの状態を保持する場合, コールステートフルと呼ばれます. コールステートフルプロキシは常にトランザクションステートフルですが, 逆は必ずしも真ではありません.

  Client: クライアントとは, SIP リクエストを送信し, SIP 応答を受信するネットワーク要素です. クライアントは人間のユーザと直接対話してもしなくても構いません. ユーザエージェントクライアントとプロキシはクライアントです.

  Conference: 複数の参加者を含むマルチメディアセッション (後述).

  Core: コアは, 特定の種類の SIP エンティティ, すなわちステートフルまたはステートレスプロキシ, ユーザエージェント, またはレジストラに固有の機能を指します. ステートレスプロキシのコアを除くすべてのコアはトランザクションユーザです.

  Dialog: ダイアログとは, 一定時間継続する 2 つの UA 間のピアツーピアの SIP 関係です. ダイアログは, INVITE リクエストに対する 2xx 応答などの SIP メッセージによって確立されます. ダイアログは, コール識別子, ローカルタグ, およびリモートタグによって識別されます. ダイアログは, RFC 2543 ではかつてコールレッグと呼ばれていました.

  Downstream: トランザクション内のメッセージ転送の方向で, リクエストがユーザエージェントクライアントからユーザエージェントサーバへ流れる方向を指します.

  Final Response: 暫定的な応答がそうでないのに対し, SIP トランザクションを終了させる応答. すべての 2xx, 3xx, 4xx, 5xx, 6xx 応答は最終応答です.

  Header: ヘッダとは, メッセージに関する情報を伝える SIP メッセージの構成要素です. 一連のヘッダフィールドとして構成されます.

  Header Field: ヘッダフィールドとは, SIP メッセージヘッダの構成要素です. ヘッダフィールドは, 1 つ以上のヘッダフィールド行として現れることがあります. ヘッダフィールド行は, ヘッダフィールド名と 0 個以上のヘッダフィールド値からなります. あるヘッダフィールド行の複数のヘッダフィールド値はカンマで区切られます. 単一のヘッダフィールド値しか持てないヘッダフィールドもあり, その結果として常に単一のヘッダフィールド行として現れます.

  Header Field Value: ヘッダフィールド値とは, 単一の値です. ヘッダフィールドは 0 個以上のヘッダフィールド値から構成されます.

  Home Domain: SIP ユーザにサービスを提供するドメイン. 典型的には, これは登録のアドレス・オブ・レコード内の URI に存在するドメインです.

  Informational Response: 暫定的な応答と同じ.

  Initiator, Calling Party, Caller: INVITE リクエストを用いてセッション (およびダイアログ) を開始する側. 発信者は, ダイアログを確立した初期 INVITE を送信した時から, そのダイアログが終了するまでこの役割を保持します.

  Invitation: INVITE リクエスト.

  Invitee, Invited User, Called Party, Callee: 新しいセッションを確立するための INVITE リクエストを受信する側. 被呼者は, INVITE を受信した時から, その INVITE によって確立されたダイアログが終了するまでこの役割を保持します.

  Location Service: ロケーションサービスは, SIP リダイレクトまたはプロキシサーバによって, 被呼者の可能性のある位置に関する情報を得るために使用されます. アドレス・オブ・レコードのキーと 0 個以上のコンタクトアドレスのバインディングのリストを含みます. バインディングはさまざまな方法で作成および削除できます. 本仕様はバインディングを更新する REGISTER メソッドを定義します.

  Loop: プロキシに到達し, 転送され, その後再び同じプロキシに到達するリクエスト. 2 回目に到達したとき, その Request-URI は 1 回目と同一であり, プロキシの動作に影響する他のヘッダフィールドも変わっていないため, プロキシは 1 回目と同じ処理決定を行います. ループしたリクエストはエラーであり, それらを検出し処理する手順はプロトコルによって記述されます.

  Loose Routing: プロキシが, Route ヘッダフィールドの処理に関する本仕様の手順に従う場合, ルーズルーティングと呼ばれます. これらの手順は, リクエストの宛先 (Request-URI に存在) と, 経路中に訪問する必要があるプロキシの集合 (Route ヘッダフィールドに存在) を分離します. これらの機構に準拠したプロキシはルーズルータとも呼ばれます.

  Message: SIP 要素間でプロトコルの一部として送信されるデータ. SIP メッセージはリクエストまたは応答のいずれかです.

  Method: メソッドとは, リクエストがサーバ上で呼び出すことを意図する主要な機能です. メソッドはリクエストメッセージ自身に含まれます. メソッドの例として INVITE や BYE があります.

  Outbound Proxy: Request-URI によって解決されるサーバではないかもしれないにもかかわらず, クライアントからリクエストを受信するプロキシ. 典型的には, UA にはアウトバウンドプロキシが手動で設定されるか, 自動設定プロトコルを通じて知ることができます.

  Parallel Search: 並列探索では, プロキシは着信リクエストを受信すると, 考えられるユーザの位置に対して複数のリクエストを発行します. 逐次探索のように 1 つリクエストを発行してから次を発行する前に最終応答を待つ代わりに, 並列探索は以前のリクエストの結果を待たずにリクエストを発行します.

  Provisional Response: サーバが進行状況を示すために使用するが, SIP トランザクションを終了させない応答. 1xx 応答は暫定的であり, 他の応答は最終応答と見なされます.

  Proxy, Proxy Server: 他のクライアントに代わってリクエストを行う目的で, サーバとクライアントの両方として動作する仲介エンティティ. プロキシサーバの主な役割はルーティングであり, リクエストが対象ユーザに "近い" 別のエンティティへ送信されるようにすることです. プロキシはポリシーの強制 (たとえばユーザが通話を行うことを許可されているか確認する) にも有用です. プロキシは, 転送前にリクエストメッセージの特定の部分を解釈し, 必要に応じて書き換えます.

  Recursion: クライアントは, 応答の Contact ヘッダフィールド内の 1 つ以上の URI に対する新しいリクエストを生成するとき, 3xx 応答に対して再帰 (recurse) します.

  Redirect Server: リダイレクトサーバとは, 受信したリクエストに対して 3xx 応答を生成し, クライアントに別の URI の集合への連絡を指示するユーザエージェントサーバです.

  Registrar: レジストラとは, REGISTER リクエストを受け入れ, それらのリクエストで受信した情報を, 自身が扱うドメインのロケーションサービスに配置するサーバです.

  Regular Transaction: 通常のトランザクションとは, INVITE, ACK, CANCEL 以外のメソッドを持つ任意のトランザクションです.

  Request: 特定の操作を呼び出す目的で, クライアントからサーバへ送信される SIP メッセージ.

  Response: クライアントからサーバへ送信されたリクエストの状態を示すために, サーバからクライアントへ送信される SIP メッセージ.

  Ringback: 着信側が呼び出し中 (鳴動中) であることを示す, 発信側のアプリケーションが生成する信号音.

  Route Set: ルートセットとは, 特定のリクエストを送信するときに通過しなければならないプロキシのリストを表す, 順序付けられた SIP または SIPS URI の集合です. ルートセットは, Record-Route などのヘッダを通じて学習されるか, 設定されます.

  Server: サーバとは, リクエストにサービスを提供するためにそれらを受信し, それらのリクエストへの応答を送り返すネットワーク要素です. サーバの例として, プロキシ, ユーザエージェントサーバ, リダイレクトサーバ, レジストラがあります.

  Sequential Search: 逐次探索では, プロキシサーバは各コンタクトアドレスを順に試み, 前のものが最終応答を生成した後にのみ次に進みます. 2xx または 6xx クラスの最終応答は常に逐次探索を終了させます.

  Session: SDP 仕様より: 「マルチメディアセッションとは, 一連のマルチメディア送信者と受信者, および送信者から受信者へ流れるデータストリームの集合である. マルチメディア会議はマルチメディアセッションの例である. 」 (RFC 2327 [1]) (SDP に対して定義されるセッションは, 1 つ以上の RTP セッションを含み得る. ) 定義上, 被呼者は同じセッションに対し, 異なる呼によって複数回招待され得ます. SDP が使用される場合, セッションは origin フィールドの SDP ユーザ名, セッション ID, ネットワーク種別, アドレス種別, およびアドレス要素の連結によって定義されます.

  SIP Transaction: SIP トランザクションは, クライアントとサーバの間で発生し, クライアントからサーバへ送信された最初のリクエストから, サーバからクライアントへ送信された最終 (非 1xx) 応答までのすべてのメッセージを含みます. リクエストが INVITE で最終応答が非 2xx の場合, そのトランザクションにはその応答に対する ACK も含まれます. INVITE リクエストに対する 2xx 応答への ACK は別のトランザクションです.

  Spiral: スパイラルとは, SIP リクエストがプロキシへルーティングされ, 転送されて再びそのプロキシに到達するが, 今度は元のリクエストとは異なる処理決定をもたらすように異なるリクエストです. 典型的には, これはリクエストの Request-URI が前回の到達時と異なることを意味します. スパイラルは, ループとは異なりエラー状態ではありません. 典型的な原因は呼転送です. ユーザが [email protected] を呼び出します. example.com プロキシはそれを Joe の PC へ転送し, さらにそれが [email protected] へ転送します. このリクエストは example.com プロキシへプロキシバックされます. しかしこれはループではありません. リクエストが異なるユーザを対象としているため, スパイラルと見なされ, 有効な状態です.

  Stateful Proxy: リクエストの処理中に, 本仕様で定義されるクライアントおよびサーバのトランザクション状態マシンを保持する論理エンティティ. トランザクションステートフルプロキシとも呼ばれます. ステートフルプロキシの動作は 16. 節でさらに定義されます. (トランザクション) ステートフルプロキシは, コールステートフルプロキシと同じではありません.

  Stateless Proxy: リクエストを処理するときに, 本仕様で定義されるクライアントまたはサーバのトランザクション状態マシンを保持しない論理エンティティ. ステートレスプロキシは, 受信したすべてのリクエストを下流へ, および受信したすべての応答を上流へ転送します.

  Strict Routing: プロキシが, RFC 2543 およびこの RFC の多くの進行中バージョンの Route 処理規則に従う場合, ストリクトルーティングと呼ばれます. その規則は, Route ヘッダフィールドが存在するときにプロキシが Request-URI の内容を破壊する原因となりました. ストリクトルーティングの動作は本仕様では使用されず, ルーズルーティングの動作が採用されています. ストリクトルーティングを行うプロキシはストリクトルータとも呼ばれます.

  Target Refresh Request: ダイアログ内で送信されるターゲットリフレッシュリクエストとは, ダイアログのリモートターゲットを変更できるリクエストとして定義されます.

  Transaction User (TU): トランザクションレイヤの上に存在するプロトコル処理の層. トランザクションユーザには, UAC コア, UAS コア, およびプロキシコアが含まれます.

  Upstream: トランザクション内のメッセージ転送の方向で, 応答がユーザエージェントサーバからユーザエージェントクライアントへ流れる方向を指します.

  URL-encoded: RFC 2396 のセクション 2.4 [5] に従って符号化された文字列.

  User Agent Client (UAC): ユーザエージェントクライアントとは, 新しいリクエストを作成し, クライアントのトランザクション状態機構を用いてそれを送信する論理エンティティです. UAC の役割は, そのトランザクションの期間中のみ続きます. すなわち, あるソフトウェアがリクエストを開始する場合, そのトランザクションの期間中は UAC として動作します. 後でリクエストを受信した場合, そのトランザクションの処理においてユーザエージェントサーバの役割を担います.

  UAC Core: UAC に必要な, トランザクションおよびトランスポート層の上に存在する一連の処理機能.

  User Agent Server (UAS): ユーザエージェントサーバとは, SIP リクエストに対する応答を生成する論理エンティティです. 応答は, リクエストを受け入れ, 拒否, またはリダイレクトします. この役割は, そのトランザクションの期間中のみ続きます. すなわち, あるソフトウェアがリクエストに応答する場合, そのトランザクションの期間中は UAS として動作します. 後でリクエストを生成した場合, そのトランザクションの処理においてユーザエージェントクライアントの役割を担います.

  UAS Core: UAS に必要な, トランザクションおよびトランスポート層の上に存在する一連の処理機能.

  User Agent (UA): ユーザエージェントクライアントおよびユーザエージェントサーバの両方として動作でき得る論理エンティティ.

UAC と UAS の役割, ならびにプロキシおよびリダイレクトサーバは, トランザクションごとに定義されます. たとえば, 呼を開始するユーザエージェントは, 初期の INVITE リクエストを送信するときは UAC として, 被呼者から BYE リクエストを受信するときは UAS として動作します. 同様に, 同じソフトウェアが, あるリクエストに対してはプロキシサーバとして, 次のリクエストに対してはリダイレクトサーバとして動作できます.

上記で定義したプロキシ, ロケーション, およびレジストラサーバは論理的エンティティです. 実装はそれらを単一のアプリケーションに統合しても構いません.