Zum Hauptinhalt springen

1. Einleitung

Ein Mittel, um die Beziehungen zwischen Ressourcen im Web anzugeben und zugleich die Art dieser Beziehungen zu kennzeichnen, ist seit einiger Zeit in HTML [W3C.REC-html401-19991224] und seit jüngerer Zeit in Atom [RFC4287] verfügbar. Diese Mechanismen sind zwar konzeptionell ähnlich, werden jedoch getrennt spezifiziert. Links zwischen Ressourcen müssen allerdings nicht formatspezifisch sein; es kann nützlich sein, typisierte Links (typed links) zu haben, die unabhängig von ihrer Serialisierung sind, insbesondere wenn eine Ressource Repräsentationen in mehreren Formaten besitzt.

Zu diesem Zweck definiert dieses Dokument einen Rahmen (framework) für typisierte Links, der nicht auf eine bestimmte Serialisierung oder Anwendung beschränkt ist. Es tut dies, indem es das von Atom eingerichtete Register für Link-Beziehungen (link relation registry) neu definiert, sodass es einen breiteren Geltungsbereich erhält, und ihm die von HTML definierten Beziehungen hinzufügt.

Darüber hinaus wurde ein HTTP-Header-Feld zur Übermittlung typisierter Links in Abschnitt 19.6.2.4 von [RFC2068] definiert, aber wegen fehlender Implementierungserfahrung aus [RFC2616] entfernt. Seitdem wurde es in einigen User Agents implementiert (z. B. für Stylesheets), und es sind mehrere zusätzliche Anwendungsfälle aufgetaucht.

Da es entfernt wurde, ist der Status des Link-Headers unklar, was einige dazu veranlasst, stattdessen neue anwendungsspezifische HTTP-Header zu prägen, anstatt ihn wiederzuverwenden. Dieses Dokument begegnet dem, indem es den Link-Header als eine solche Serialisierung neu spezifiziert, mit aktualisierter, aber abwärtskompatibler Syntax.