2. Einleitung (Introduction)
Mehrere Bereiche der Domain Name System-Spezifikation [RFC1034, RFC1035] wurden im Laufe der Jahre als problematisch identifiziert [RFC1123]. Dieses Dokument befasst sich mit einigen weiteren Bereichen. Die Probleme hier sind unabhängig voneinander. Sie umfassen: das Problem, welche Quelladresse ein multi-homed DNS-Server bei der Beantwortung einer Abfrage verwenden soll, das Problem unterschiedlicher TTLs für dasselbe Label, dieselbe Klasse und denselben Typ eines DNS-Eintrags sowie die Frage der kanonischen Namen — was sie sind, wie CNAME-RRs zusammenhängen, welche Namen in welchen Teilen des DNS zulässig sind und wie die gültige Syntax eines DNS-Namens aussieht.
Um diese Probleme zu vermeiden, klärt dieses Memo die DNS-Spezifikation. Es korrigiert außerdem eine kleine Mehrdeutigkeit in RFC1034 bezüglich SOA-RRs, eine Mehrdeutigkeit in der Definition der TTL (Time To Live) und eine mögliche Verwirrung bei der Verwendung des TC-Bits.