2. はじめに (Introduction)
長年にわたり、ドメインネームシステム仕様 (Domain Name System specification) [RFC1034, RFC1035] のいくつかの領域が問題ありとして識別されてきました [RFC1123]。 本書はさらにいくつかの領域を扱います。ここでの問題は互いに独立しており、以下を 含みます。マルチホーム (multi-homed) の DNS サーバーが問い合わせに応答する際に使用 すべき送信元アドレスはどれかという問題、同じラベル・クラス・タイプの DNS レコードに ついて異なる TTL が存在するという問題、および正規名 (canonical names) とは何か、 CNAME レコードはどう関連するか、DNS のどの部分でどの名前が合法か、DNS 名の有効な 構文は何か、という問題です。
これらの問題を避けるため、本メモは DNS 仕様を明確にします。また、SOA レコードに 関する RFC1034 のわずかな曖昧さ、TTL (生存時間、Time To Live) の定義における 曖昧さ、および TC ビットの使用における考えられる混乱を修正します。