2. Introduction
Several areas of the Domain Name System specification [RFC1034, RFC1035] have been identified as problematic over the years [RFC1123]. This document deals with some additional areas. The problems here are independent. They include: the problem of which source address a multi-homed DNS server should use when responding to a query, the problem of differing TTLs for the same labels, class and type of DNS record, and the issue of canonical names - what they are, how CNAME RRs relate, which names are legal in which parts of the DNS, and what is the valid syntax of a DNS name.
To avoid these problems, this memo clarifies the DNS specification. It also corrects a minor ambiguity in RFC1034 concerning SOA RRs, an ambiguity in the definition of the TTL (Time To Live), and a possible confusion in the use of the TC bit.