2. Introduzione (Introduction)
Diversi ambiti delle specifiche del Domain Name System (DNS) [RFC1034, RFC1035] sono stati identificati come problematici nel corso degli anni [RFC1123]. Questo documento tratta alcuni ambiti aggiuntivi. I problemi qui sono indipendenti. Essi includono: il problema di quale indirizzo di origine un server DNS multi-homed debba utilizzare quando risponde a una query, il problema di diversi TTL per la stessa etichetta, classe e tipo di record DNS, e la questione dei nomi canonici — cosa siano, come si collegano i RR CNAME, quali nomi siano legali in quali parti del DNS e quale sia la sintassi valida di un nome DNS.
Per evitare questi problemi, questo memo chiarisce la specifica DNS. Corregge inoltre una piccola ambiguità in RFC1034 riguardante i RR SOA, un'ambiguità nella definizione del TTL (Time To Live) e una possibile confusione nell'uso del bit TC.