11. Sintassi dei nomi (Name syntax)
Questa sezione tratta la sintassi dei nomi DNS. Un nome DNS è una sequenza di etichette separate da punti. Ogni etichetta è una sequenza di caratteri, con lunghezza massima di 63 caratteri. La lunghezza totale di un nome di dominio (inclusi i punti) è limitata a 255 caratteri. Questo è un cambiamento rispetto a RFC1034, che limitava la lunghezza di un nome di dominio a 255 ottetti (byte), non a 255 caratteri.
I caratteri consentiti in un'etichetta sono: lettere (A-Z e a-z), cifre (0-9) e il trattino (-). Il primo e l'ultimo carattere di un'etichetta non devono essere un trattino. Le etichette non fanno distinzione tra maiuscole e minuscole. Cioè, "example.COM" e "example.com" sono lo stesso nome.
Il carattere di sottolineatura (_) non è consentito in un'etichetta, eccetto nel caso particolare dei record di localizzazione dei servizi (SRV) [RFC2052], in cui il sottolineatura viene utilizzato per prefissare i nomi di servizio e protocollo.
Qualsiasi stringa binaria può essere rappresentata come un'etichetta DNS, utilizzando il prefisso "xn--" (per la codifica Punycode [RFC3492]) o utilizzando la notazione "[" (per una sequenza di ottetti sottoposta a escape). Questo consente ai nomi DNS di contenere caratteri che non fanno parte del set di caratteri standard.
Un nome DNS non deve contenere caratteri non consentiti in un'etichetta. Cioè, caratteri come "/" e ":" non sono consentiti in un nome DNS.
L'etichetta radice ("") è un caso speciale. È l'unica etichetta che non è una sequenza di caratteri. È rappresentata da un punto alla fine del nome.