Aller au contenu principal

11. Syntaxe des noms (Name syntax)

Cette section traite de la syntaxe des noms DNS. Un nom DNS est une séquence de labels, séparés par des points. Chaque label est une séquence de caractères, d'une longueur maximale de 63 caractères. La longueur totale d'un nom de domaine (points compris) est limitée à 255 caractères. Cela constitue un changement par rapport à la RFC1034, qui limitait la longueur d'un nom de domaine à 255 octets, et non à 255 caractères.

Les caractères autorisés dans un label sont : les lettres (A-Z et a-z), les chiffres (0-9), et le trait d'union (-). Le premier et le dernier caractère d'un label ne doivent pas être un trait d'union. Les labels ne sont pas sensibles à la casse. C'est-à-dire que « example.COM » et « example.com » sont le même nom.

Le caractère souligné (_) n'est pas autorisé dans un label, à l'exception du cas particulier des enregistrements de localisation de service (SRV) [RFC2052], où le souligné est utilisé pour préfixer les noms de service et de protocole.

Toute chaîne binaire peut être représentée comme un label DNS, en utilisant le préfixe « xn-- » (pour le codage Punycode [RFC3492]), ou en utilisant la notation « [ » (pour une séquence d'octets échappée). Cela permet aux noms DNS de contenir des caractères qui ne font pas partie du jeu de caractères standard.

Un nom DNS ne doit contenir aucun caractère non autorisé dans un label. C'est -à-dire que des caractères tels que « / » et « : » ne sont pas autorisés dans un nom DNS.

Le label racine ("") est un cas particulier. C'est le seul label qui n'est pas une séquence de caractères. Il est représenté par un point à la fin du nom.