3. Terminologie (Terminology)
Dans ce document, les mots-clés « MUST », « MUST NOT », « REQUIRED », « SHALL », « SHALL NOT », « SHOULD », « SHOULD NOT », « RECOMMENDED », « MAY » et « OPTIONAL » doivent être interprétés comme décrit dans la RFC 2119 [RFC2119].
Les définitions suivantes sont utilisées dans ce document :
Nom (Name) : Un nom est une séquence de labels. La racine de l'arbre DNS est appelée « la racine (the root) » et est écrite comme un label de longueur nulle (""). Le nom de domaine pleinement qualifié (FQDN) d'un nœud dans le DNS est la concaténation de tous les labels sur le chemin du nœud vers la racine, séparés par des points (« . »), la racine elle-même étant désignée par un point à la fin du nom. Par « concaténation », nous entendons que les labels sont disposés dans l'ordre inverse (de la feuille vers la racine) de la séquence de labels qui parcourt le chemin de la racine vers le nœud. Lorsque le FQDN est écrit comme une séquence de caractères (plutôt que comme une séquence de labels), tous les labels sont en majuscules ou en minuscules de façon uniforme.
Label : Un label est un composant individuel d'un nom de domaine. Dans la notation texte à points d'un nom de domaine, les labels sont les chaînes de caractères séparées par des points. Notez que la longueur d'un label, dans ce contexte, est mesurée en caractères (et non en octets). La longueur maximale d'un label est de 63 caractères. La représentation textuelle d'un label est une chaîne de caractères utilisée pour représenter le label. Il existe deux types de labels : les labels « données », définis à la section 11, et les labels de « compression », décrits à la section 4.1.4 de la RFC1035.
Nom de domaine (Domain Name) : Un nom de domaine est un nom dans le système de noms de domaine. Un nom de domaine est une séquence de labels. Un nom de domaine est écrit comme une séquence de labels séparés par des points. Un nom de domaine est dit « absolu » (ou « pleinement qualifié ») s'il inclut le label racine (c'est-à-dire s'il se termine par un point). Un nom de domaine est dit « relatif » s'il n'inclut pas le label racine.
RR (Resource Record, enregistrement de ressource) : Un Resource Record est un membre de la classe de structures de données contenues dans les fichiers de zone (ou dans le DNS), et qui possèdent une structure particulière, telle que définie dans la RFC1035. Un RR est composé des champs NAME, TYPE, CLASS, TTL, RDLENGTH et RDATA.
RRSet (Resource Record Set, ensemble de records de ressource) : Un RRSet est un ensemble d'un ou plusieurs RR ayant le même NAME, CLASS et TYPE. Le TTL de tous les RR d'un RRSet doit être identique (voir section 5.2).
Zone : Une zone est une collection de domaines, implémentée dans un fichier de données particulier, et gérée par un serveur de noms particulier. Une zone peut être, et est souvent, un seul domaine. Elle peut aussi être un ensemble de domaines. Aux fins du présent document, l'aspect important d'une zone est qu'elle constitue l'unité de contrôle administratif. C'est -à-dire que la zone est la plus petite collection de domaines dont les modifications sont contrôlées par une seule entité. C'est également l'unité de transfert (voir section 6 de la RFC1034) et l'unité de mise en cache.
Autoritatif (Authoritative) : Le serveur faisant autorité pour une zone est le serveur qui détient les données de la zone. Une réponse est autoritative si elle provient du serveur faisant autorité pour la zone. Une réponse n'est pas autoritative si elle provient d'un serveur qui n'est pas le serveur faisant autorité pour la zone, ou si elle provient d'un cache.
Cache : Un cache est une copie locale d'une portion du DNS. Un cache est maintenu par un résolveur, et est utilisé pour réduire la charge sur le DNS en évitant d'interroger le DNS pour des données susceptibles d'être fréquemment utilisées. Un cache ne contient aucune donnée autoritative.
Résolveur (Resolver) : Un résolveur est un programme utilisé pour extraire des informations du DNS. Un résolveur peut être un résolveur stub (qui transfère toutes les requêtes à un résolveur récursif), ou un résolveur récursif (qui exécute lui-même les requêtes).