3. 术语 (Terminology)
在本文档中,关键词 "MUST"、"MUST NOT"、"REQUIRED"、"SHALL"、"SHALL NOT"、"SHOULD"、"SHOULD NOT"、"RECOMMENDED"、"MAY" 和 "OPTIONAL" 的解释如 RFC 2119 [RFC2119] 所述。
本文档使用以下定义:
名称 (Name): 名称是一系列标签的序列. DNS 树的根称为 "根 (the root)",写作一个 零长度标签 (""). 一个节点的完全限定域名 (FQDN) 是从该节点到根路径上 所有标签的连接,以圆点 (".") 分隔,根本身以名称末尾的圆点表示. 所谓 "连接",是指标签按从叶子到根的逆序排列,对应于从根到节点的路径上标签 的顺序. 当 FQDN 写作字符串序列(而非标签序列)时,所有标签都使用相同 的大写或小写形式.
标签 (Label): 标签是域名的一个独立组成部分. 在域名的点分字符串表示中,标签是由圆点 分隔的字符串. 注意,在此上下文中,标签的长度以字符(而非字节或八位组) 计. 标签的最大长度为 63 个字符. 标签的文本表示是用于表示它的字符串. 标签有两种:"数据"标签(在第 11 节中定义)和 "压缩"标签(在 RFC1035 的 4.1.4 节描述).
域名 (Domain Name): 域名是域名系统中的名称. 域名是一系列标签的序列,写作由圆点分隔的标签 序列. 如果域名包含根标签(即以圆点结尾),则称为 "绝对"域名(或 "完全 限定"). 如果不包含根标签,则称为 "相对"域名.
资源记录 (RR, Resource Record): 资源记录是包含在区域文件(或 DNS)中的一类数据结构,具有 RFC1035 中 定义的特定结构. 一个 RR 由 NAME、TYPE、CLASS、TTL、RDLENGTH 和 RDATA 字段组成.
资源记录集 (RRSet, Resource Record Set): 一个 RRSet 是具有相同 NAME、CLASS 和 TYPE 的一个或多个 RR 的集合. RRSet 中所有 RR 的 TTL 必须相同(见第 5.2 节).
区域 (Zone): 区域是域名的一个集合,实现于特定的数据文件中,并由特定的名称服务器管理. 一个区域可以(且通常是)单个域名,也可以是一组域名. 就本文档而言,区域 的重要方面在于它是管理控制的单位,即区域是受单一实体控制变更的最小 域名集合. 它也是传输单位(见 RFC1034 第 6 节)和缓存单位.
权威 (Authoritative): 区域的权威服务器是拥有该区域数据的服务器. 若应答来自该区域的权威 服务器,则该应答是权威的. 若应答来自非该区域权威服务器的服务器,或来自 缓存,则该应答不是权威的.
缓存 (Cache): 缓存是 DNS 一部分内容的本地副本,由解析器维护,用于减少 DNS 负载,避免 对可能频繁使用的数据重复查询. 缓存不包含任何权威数据.
解析器 (Resolver): 解析器是用于从 DNS 提取信息的程序. 解析器可以是存根解析器(将所有查询 转发给递归解析器),也可以是递归解析器(自行执行查询).