3. Terminologia (Terminology)
In questo documento, le parole chiave "MUST", "MUST NOT", "REQUIRED", "SHALL", "SHALL NOT", "SHOULD", "SHOULD NOT", "RECOMMENDED", "MAY" e "OPTIONAL" devono essere interpretate come descritto in RFC 2119 [RFC2119].
In questo documento si utilizzano le seguenti definizioni:
Nome (Name): Un nome è una sequenza di etichette (label). La radice dell'albero DNS è detta "la radice (the root)" e viene scritta come un'etichetta di lunghezza zero (""). Il nome di dominio completamente qualificato (FQDN) di un nodo nel DNS è la concatenazione di tutte le etichette sul percorso dal nodo alla radice, separate da punti ("."), con la radice stessa indicata da un punto alla fine del nome. Con "concatenazione" si intende che le etichette sono disposte in una sequenza in ordine inverso (dalla foglia alla radice) rispetto alla sequenza di etichette che attraversa il percorso dalla radice al nodo. Quando l'FQDN è scritto come sequenza di caratteri (anziché come sequenza di etichette), tutte le etichette sono in maiuscolo o in minuscolo.
Etichetta (Label): Un'etichetta è una componente individuale di un nome di dominio. Nella notazione a stringa puntata di un nome di dominio, le etichette sono le stringhe di caratteri separate da punti. Si noti che la lunghezza di un'etichetta, in questo contesto, è misurata in caratteri (non byte o ottetti). La lunghezza massima di un'etichetta è di 63 caratteri. La rappresentazione testuale di un'etichetta è una stringa di caratteri utilizzata per rappresentare l'etichetta. Esistono due tipi di etichette: le etichette "dati", definite nella sezione 11, e le etichette di "compressione", descritte nella sezione 4.1.4 di RFC1035.
Nome di dominio (Domain Name): Un nome di dominio è un nome nel sistema dei nomi di dominio. Un nome di dominio è una sequenza di etichette. Un nome di dominio è scritto come una sequenza di etichette separate da punti. Un nome di dominio si dice "assoluto" (o "completamente qualificato") se include l'etichetta radice (cioè se termina con un punto). Un nome di dominio si dice "relativo" se non include l'etichetta radice.
RR (Resource Record): Un Resource Record è un membro della classe di strutture dati contenute nei file di zona (o nel DNS) e che hanno una particolare struttura, come definito in RFC1035. Un RR è composto dai campi NAME, TYPE, CLASS, TTL, RDLENGTH e RDATA.
RRSet (Resource Record Set): Un RRSet è un insieme di uno o più RR con lo stesso NAME, CLASS e TYPE. Il TTL di tutti gli RR in un RRSet deve essere lo stesso (vedere la sezione 5.2).
Zona (Zone): Una zona è una collezione di domini, implementata in un particolare file di dati e gestita da un particolare server dei nomi. Una zona può essere, e spesso è, un singolo dominio. Può anche essere una collezione di domini. Ai fini di questo documento, l'aspetto importante di una zona è che essa è l'unità di controllo amministrativo. Cioè, la zona è la più piccola collezione di domini sulla quale le modifiche sono controllate da una singola entità. È anche l'unità di trasferimento (vedere la sezione 6 di RFC1034) e l'unità di caching.
Autorevole (Authoritative): Il server autorevole per una zona è il server che possiede i dati per la zona. Una risposta è autorevole se proviene dal server autorevole per la zona. Una risposta non è autorevole se proviene da un server che non è il server autorevole per la zona, o se proviene da una cache.
Cache: Una cache è una copia locale di una porzione del DNS. Una cache è mantenuta da un resolver ed è utilizzata per ridurre il carico sul DNS eliminando la necessità di interrogare il DNS per dati che è probabile vengano usati frequentemente. Una cache non contiene dati autorevoli.
Resolver: Un resolver è un programma utilizzato per estrarre informazioni dal DNS. Un resolver può essere uno stub resolver (che inoltra tutte le query a un resolver ricorsivo), oppure un resolver ricorsivo (che esegue le query esso stesso).