4. 安全考虑
由于 UTF-8 常常需要多个八位组来编码单个字符, 国际化可能导致头部字段值 (一般而言) 和邮件地址 (尤其如此) 变得更长. 如 [RFC5322] 所规定, 每行字符禁止 (MUST NOT) 超过 998 个八位组, 不包括 CRLF. 另一方面, 解析, 存储或处理电子邮件地址或 local part 的 MDA (Mail Delivery Agent) 进程必须格外小心, 以免缓冲区溢出, 地址被截断或超出存储配额. 此外, 在比较时它们必须注意使用地址的完整长度.
使用 UTF-8 表示与某个特定显示字符或字符组等价或相似的内容有很多种方式; 有关由此引发的问题的细节, 见 [RFC3629] 的安全考虑. 为尽量减少这些问题, 推荐采用第 3.1 节所述的规范化处理.
UTF-8 头部对 Domain Keys Identified Mail (DKIM), S/MIME 和 OpenPGP 等电子邮件签名系统的安全影响, 在 [RFC6530] 第 14 节中讨论.
如果某个用户既有非 ASCII 邮箱地址又有 ASCII 邮箱地址, 那么标识该用户的数字证书可能在其身份中同时包含这两个地址. 在单个证书中把多个电子邮件地址作为身份, PKIX (Public Key Infrastructure using X.509) [RFC5280] 和 OpenPGP [RFC3156] 已经支持, 但在这种语境下把 UTF-8 引入地址可能会带来用户界面方面的问题.