4. Considerazioni sulla sicurezza
Poiché UTF-8 richiede spesso diversi ottetti per codificare un singolo carattere, l'internazionalizzazione può far diventare più lunghi i valori dei campi di intestazione (in generale) e gli indirizzi di posta (in particolare). Come specificato in [RFC5322], ogni riga di caratteri non deve (MUST NOT) superare i 998 ottetti, esclusi i CRLF. D'altra parte, i processi MDA (Mail Delivery Agent) che analizzano, memorizzano o gestiscono indirizzi di posta o parti locali devono prestare particolare attenzione a non superare i limiti dei buffer, a non troncare gli indirizzi e a non eccedere le quote di archiviazione. Inoltre, in fase di confronto, devono prestare attenzione a utilizzare l'intera lunghezza degli indirizzi.
Esistono molti modi per usare UTF-8 al fine di rappresentare qualcosa di equivalente o simile a un particolare carattere visualizzato o gruppo di caratteri; per i dettagli sui problemi che ciò può causare, vedere le considerazioni sulla sicurezza in [RFC3629]. Il processo di normalizzazione descritto nella sezione 3.1 è raccomandato per ridurre al minimo tali problemi.
L'impatto sulla sicurezza delle intestazioni UTF-8 sui sistemi di firma della posta elettronica quali Domain Keys Identified Mail (DKIM), S/MIME e OpenPGP è discusso nella sezione 14 di [RFC6530].
Se un utente ha sia un indirizzo di casella di posta non ASCII sia un indirizzo di casella di posta ASCII, un certificato digitale che identifica tale utente potrebbe contenere entrambi gli indirizzi nell'identità. La presenza di più indirizzi di posta elettronica come identità in un singolo certificato è già supportata in PKIX (Public Key Infrastructure using X.509) [RFC5280] e OpenPGP [RFC3156], ma in questo contesto possono sorgere problemi di interfaccia utente associati all'introduzione di UTF-8 negli indirizzi.