跳到主要内容

1. 引言

Internet 邮件将消息与其传输区分开来, 并进一步把消息划分为头部和正文 [RFC5322]. Internet 邮件的头部字段值包含各种面向用户可见的字符串. 这些字符串最初支持的字符范围被限制为 7-bit 形式的 [ASCII]. MIME [RFC2045] [RFC2046] [RFC2047] 提供了使用其他字符集的能力, 但这种支持仅限于正文部分数据, 以及仅允许出现在头部字段值中少数位置的专用编码词 (encoded-word) 构造.

Internet 的全球化要求在邮件地址和大多数头部字段值中支持 Unicode [RFC5198] 所提供的规模大得多的字符集. 此外, 诸如编码词之类的复杂编码方案不仅带来低效, 还制造了大量处理错误的机会. 最后, 大多数系统现在都已原生支持 UTF-8 字符集. 因此, 让 Internet 邮件直接支持 UTF-8 [RFC3629] 是非常可取的.

本文档规定了对 Internet Message Format [RFC5322] 和 MIME 的增强, 允许在头部字段值 (包括邮件地址) 中直接使用 UTF-8, 而不再仅限于 ASCII. 对于使用这种扩展格式的消息, 定义了一种新的媒体类型 message/global. 本规范还取消了 MIME 中禁止对 message 顶级类型的任何子类型使用非 identity 内容传输编码的限制, 从而使 message/global 部分能够安全地穿越现有的邮件基础设施进行传输.

本规范基于对 UTF-8 的原生端到端支持模型, 该模型依赖于由传输系统保证的 "8-bit-clean" 环境. 要支持穿越传统 7-bit 基础设施传输以及由 7-bit 接收方处理, 还需要本规范未提供的其他机制.

本规范是 [RFC5335] 的修订版和替代版本. [RFC6530] 第 6 节描述了本规范与先前版本在方法上的变化.