Passa al contenuto principale

1. Introduzione

La posta Internet distingue un messaggio dal suo trasporto e suddivide ulteriormente un messaggio in un'intestazione e un corpo [RFC5322]. I valori dei campi di intestazione della posta Internet contengono varie stringhe destinate a essere visibili all'utente. L'intervallo di caratteri supportati per queste stringhe era originariamente limitato all'[ASCII] in forma a 7 bit. MIME [RFC2045] [RFC2046] [RFC2047] fornisce la capacità di utilizzare set di caratteri aggiuntivi, ma questo supporto è limitato ai dati delle parti del corpo e a speciali costrutti di parole codificate (encoded-word) consentiti solo in un numero limitato di posizioni nei valori dei campi di intestazione.

La globalizzazione di Internet richiede il supporto dell'insieme molto più ampio di caratteri fornito da Unicode [RFC5198] sia negli indirizzi di posta sia nella maggior parte dei valori dei campi di intestazione. Inoltre, schemi di codifica complessi come le parole codificate introducono inefficienze nonché notevoli opportunità di errori di elaborazione. Infine, il supporto nativo per il set di caratteri UTF-8 è ormai disponibile sulla maggior parte dei sistemi. Pertanto, è fortemente auspicabile che la posta Internet supporti direttamente UTF-8 [RFC3629].

Questo documento specifica un miglioramento dell'Internet Message Format [RFC5322] e di MIME che consente l'uso diretto di UTF-8, anziché del solo ASCII, nei valori dei campi di intestazione, compresi gli indirizzi di posta. Per i messaggi che utilizzano questo formato esteso viene definito un nuovo tipo di media, message/global. Questa specifica elimina inoltre la restrizione MIME che vieta l'uso di content-transfer-encoding non identity su qualsiasi sottotipo del tipo di primo livello message, affinché le parti message/global possano essere trasmesse in modo sicuro attraverso l'infrastruttura di posta esistente.

Questa specifica si basa su un modello di supporto nativo end-to-end per UTF-8, che dipende dalla disponibilità di un ambiente "8-bit-clean" assicurato dal sistema di trasporto. Il supporto per il transito attraverso infrastrutture legacy a 7 bit e per l'elaborazione da parte di riceventi a 7 bit richiede meccanismi aggiuntivi che non sono forniti da queste specifiche.

Questa specifica è una revisione di [RFC5335] e lo sostituisce. La sezione 6 di [RFC6530] descrive il cambiamento di approccio tra questa specifica e la versione precedente.