跳到主要内容

7. IANA 注意事项

本文档没有引入新的 IANA 注意事项,因为本文档中使用的所有协议参数都已被先前的规范分配。然而,由于 DNSSEC 的发展历程漫长且有些曲折,本节试图描述与 DNSSEC 相关(或曾经相关)的 IANA 注册表及其他协议参数的当前状态。

更多 IANA 注意事项见 [RFC4035]。

DNS 资源记录类型:[RFC2535] 将类型 24、25 和 30 分配给 SIG、KEY 和 NXT 资源记录。[RFC3658] 将 DNS 资源记录类型 43 分配给 DS 资源记录。[RFC3755] 将类型 46、47 和 48 分配给 RRSIG、NSEC 和 DNSKEY 资源记录。[RFC3755] 还将类型 30(NXT)标记为废弃(obsolete),并将类型 24(SIG)和 25(KEY)的使用限制于 [RFC2931] 中描述的"SIG(0)"事务安全协议以及 [RFC2930] 中描述的事务 KEY 资源记录。

DNS 安全算法编号:[RFC2535] 创建了用于 DNSSEC 资源记录算法字段编号的 IANA 注册表,并分配了值 1-4 以及 252-255。[RFC3110] 分配了值 5。[RFC3755] 修改了该注册表,增加了一个标志(flags)字段,用于指示每个条目在 DNS 安全扩展中的使用状态:是强制(mandated)、推荐(recommended)、可选(optional),还是不得使用(must not be used)。每个算法条目可以引用可用于区域签名(zone signing)、事务安全(见 [RFC2931])或两者的算法。值 6-251 可通过 IETF 标准行动(Standards Action,见 [RFC3755])分配。关于 DNS 安全算法编号条目及其在 DNSSEC 中使用状态的完整列表,见附录 A。

[RFC3658] 创建了 DNSSEC DS 摘要类型(DS digest types)的 IANA 注册表,并将值 0 分配给保留(Reserved),将值 1 分配给 SHA-1。

KEY 协议值:[RFC2535] 创建了 KEY 协议值的 IANA 注册表,但 [RFC3445] 将除 3 以外的所有值重新分配为保留(Reserved),并关闭了该 IANA 注册表。该注册表保持关闭状态,所有 KEY 和 DNSKEY 记录都必须将协议八位组(protocol octet)值设为 3。

KEY 和 DNSKEY 资源记录中的标志位:[RFC3755] 创建了 DNSSEC KEY 和 DNSKEY 资源记录标志位的 IANA 注册表。最初,该注册表仅包含位 7(ZONE 位)和位 15(Secure Entry Point 标志(SEP)位;见 [RFC3757])的分配。位 0-6 和位 8-14 可通过 IETF 标准行动分配,如 [RFC3755] 所述。


相关章节导航: