7. Considérations IANA
Ce document n'introduit aucune nouvelle considération IANA, car tous les paramètres de protocole utilisés dans ce document ont déjà été assignés par des spécifications antérieures. Toutefois, l'historique de DNSSEC ayant été long et quelque peu complexe, cette section tente de décrire l'état actuel des registres IANA et des autres paramètres de protocole associés (ou ayant été associés) à DNSSEC.
Pour d'autres considérations IANA, voir [RFC4035].
Types d'enregistrements de ressources DNS : [RFC2535] a assigné les types 24, 25 et 30 aux enregistrements de ressources SIG, KEY et NXT. [RFC3658] a assigné le type 43 DNS aux enregistrements de ressources DS. [RFC3755] a assigné les types 46, 47 et 48 aux enregistrements de ressources RRSIG, NSEC et DNSKEY. [RFC3755] a également marqué le type 30 (NXT) comme obsolète et a limité l'utilisation des types 24 (SIG) et 25 (KEY) au protocole de sécurité de transaction « SIG(0) » décrit dans [RFC2931] et à l'enregistrement de ressources de clé de transaction décrit dans [RFC2930].
Numéros d'algorithmes de sécurité DNS : [RFC2535] a créé le registre IANA pour la numérotation des champs d'algorithme des enregistrements de ressources DNSSEC et a assigné les valeurs 1-4 ainsi que 252-255. [RFC3110] a assigné la valeur 5. [RFC3755] a modifié ce registre en ajoutant un champ d'indicateurs (flags) indiquant, pour chaque entrée, le statut d'utilisation dans les extensions de sécurité DNS : obligatoire (mandated), recommandé (recommended), optionnel (optional) ou à ne pas utiliser (must not be used). Chaque entrée d'algorithme peut faire référence à un algorithme utilisable pour la signature de zone (zone signing), la sécurité de transaction (voir [RFC2931]) ou les deux. Les valeurs 6-251 peuvent être assignées par une action standard IETF (Standards Action, voir [RFC3755]). Pour la liste complète des entrées du numéro d'algorithme de sécurité DNS et de leur statut d'utilisation dans DNSSEC, voir l'annexe A.
[RFC3658] a créé le registre IANA des types de condensé DS DNSSEC (DS digest types) et a assigné la valeur 0 à réservé (Reserved) et la valeur 1 à SHA-1.
Valeurs de protocole KEY : [RFC2535] a créé le registre IANA des valeurs de protocole KEY, mais [RFC3445] a réassigné toutes les valeurs autres que 3 comme réservées (Reserved) et a fermé ce registre IANA. Le registre reste fermé, et tous les enregistrements KEY et DNSKEY doivent avoir la valeur de l'octet de protocole (protocol octet) fixée à 3.
Bits d'indicateurs des enregistrements KEY et DNSKEY : [RFC3755] a créé le registre IANA des bits d'indicateurs (flags) des enregistrements de ressources DNSSEC KEY et DNSKEY. Initialement, ce registre ne contenait que l'assignation des bits 7 (bit ZONE) et 15 (bit Secure Entry Point (SEP) ; voir [RFC3757]). Les bits 0-6 et 8-14 peuvent être assignés par une action standard IETF, comme décrit dans [RFC3755].
Navigation entre sections :
- Précédent : 6. Forme canonique et ordre des enregistrements de ressources
- Suivant : 8. Considérations de sécurité