跳到主要内容

附录 A. DNSSEC 算法与摘要类型

本附录列出了在撰写本文档时,DNS 安全算法编号(DNSSEC Algorithm Number)注册表以及 DNSSEC DS 摘要类型(DNSSEC DS Digest Type)注册表中的条目。各条目均给出了该条目在 DNSSEC 中使用状态(mandatory / 强制、recommended / 推荐、optional / 可选,或 not recommended / 不推荐)的指示。

A.1. DNS 安全算法编号​

编号说明在 DNSSEC 中的使用状态备注
0保留(Reserved)—未分配
1RSA/MD5不推荐(NOT RECOMMENDED)见 [RFC3110]
2Diffie-Hellman可选(OPTIONAL)见 [RFC2539]
3DSA/SHA-1可选(OPTIONAL)见 [RFC2536]
4保留用于 ECC保留(Reserved)—
5RSA/SHA-1推荐(RECOMMENDED)见 [RFC3110]
6DSA-NSEC3-SHA1可选(OPTIONAL)见 [RFC5157]
7RSASHA1-NSEC3-SHA1推荐(RECOMMENDED)见 [RFC5157]
8保留用于 RSASHA256保留(Reserved)—
9RSASHA256推荐(RECOMMENDED)见 [RFC5702]
10RSASHA512可选(OPTIONAL)见 [RFC5702]
11保留用于 ECC-GOST保留(Reserved)—
12ECC-GOST可选(OPTIONAL)见 [RFC5933]
13ECDSAP256-SHA256推荐(RECOMMENDED)见 [RFC6605]
14ECDSAP384-SHA384推荐(RECOMMENDED)见 [RFC6605]
15-251未分配(Unassigned)—通过 IETF 标准行动(Standards Action)分配
252间接(Indirect)可选(OPTIONAL)见 [RFC4034] 第 2 节
253私钥(Private [explicit])可选(OPTIONAL)见 [RFC4034] 第 2 节
254私钥(Private [OID])可选(OPTIONAL)见 [RFC4034] 第 2 节
255保留(Reserved)——

注:编号 8、11 以及 15-251 区间中的值在撰写本文档时为保留或未分配;后续规范(如 [RFC5702]、[RFC5933]、[RFC6605]、[RFC5157])分配了其中部分值。为忠实反映本文档撰写时的状态,上表保留了原文所列的保留/未分配标记。

A.2. DNSSEC DS 摘要类型​

编号说明在 DNSSEC 中的使用状态
0保留(Reserved)—
1SHA-1推荐(RECOMMENDED)

相关章节导航: