Annexe A. Algorithmes et types de condensé DNSSEC
Cette annexe énumère les entrées des registres du numéro d'algorithme de sécurité DNS (DNSSEC Algorithm Number) et du type de condensé DS DNSSEC (DNSSEC DS Digest Type) au moment de la rédaction de ce document. Chaque entrée indique son statut d'utilisation dans DNSSEC (obligatoire (mandatory), recommandé (recommended), optionnel (optional) ou non recommandé (not recommended)).
A.1. Numéros d'algorithmes de sécurité DNS
| Numéro | Description | Statut d'utilisation dans DNSSEC | Remarques |
|---|---|---|---|
| 0 | Réservé (Reserved) | — | Non assigné |
| 1 | RSA/MD5 | Non recommandé (NOT RECOMMENDED) | Voir [RFC3110] |
| 2 | Diffie-Hellman | Optionnel (OPTIONAL) | Voir [RFC2539] |
| 3 | DSA/SHA-1 | Optionnel (OPTIONAL) | Voir [RFC2536] |
| 4 | Réservé pour ECC (Reserved) | Réservé (Reserved) | — |
| 5 | RSA/SHA-1 | Recommandé (RECOMMENDED) | Voir [RFC3110] |
| 6 | DSA-NSEC3-SHA1 | Optionnel (OPTIONAL) | Voir [RFC5157] |
| 7 | RSASHA1-NSEC3-SHA1 | Recommandé (RECOMMENDED) | Voir [RFC5157] |
| 8 | Réservé pour RSASHA256 (Reserved) | Réservé (Reserved) | — |
| 9 | RSASHA256 | Recommandé (RECOMMENDED) | Voir [RFC5702] |
| 10 | RSASHA512 | Optionnel (OPTIONAL) | Voir [RFC5702] |
| 11 | Réservé pour ECC-GOST (Reserved) | Réservé (Reserved) | — |
| 12 | ECC-GOST | Optionnel (OPTIONAL) | Voir [RFC5933] |
| 13 | ECDSAP256-SHA256 | Recommandé (RECOMMENDED) | Voir [RFC6605] |
| 14 | ECDSAP384-SHA384 | Recommandé (RECOMMENDED) | Voir [RFC6605] |
| 15-251 | Non assigné (Unassigned) | — | Assigné par une action standard IETF (Standards Action) |
| 252 | Indirect | Optionnel (OPTIONAL) | Voir [RFC4034] section 2 |
| 253 | Clé privée (Private [explicit]) | Optionnel (OPTIONAL) | Voir [RFC4034] section 2 |
| 254 | Clé privée (Private [OID]) | Optionnel (OPTIONAL) | Voir [RFC4034] section 2 |
| 255 | Réservé (Reserved) | — | — |
Note : les valeurs 8, 11 et celles de la plage 15-251 étaient réservées ou non assignées au moment de la rédaction de ce document. Des spécifications ultérieures (telles que [RFC5702], [RFC5933], [RFC6605], [RFC5157]) ont assigné certaines de ces valeurs. Pour refléter fidèlement l'état au moment de la rédaction, le tableau ci-dessus conserve les mentions réservé/non assigné du texte original.
A.2. Types de condensé DS DNSSEC
| Numéro | Description | Statut d'utilisation dans DNSSEC |
|---|---|---|
| 0 | Réservé (Reserved) | — |
| 1 | SHA-1 | Recommandé (RECOMMENDED) |
Navigation entre sections :
- Précédent : 10. Références
- Suivant : Annexe B. Calcul de la clé étiquette