メインコンテンツまでスキップ

付録 A. DNSSEC アルゴリズムおよびダイジェスト型

本付録は、本書の執筆時点における DNS セキュリティ・アルゴリズム番号(DNSSEC Algorithm Number)レジストリおよび DNSSEC DS ダイジェスト型(DNSSEC DS Digest Type)レジストリのエントリを列挙する。各エントリには、DNSSEC における使用状況(mandatory/強制、recommended/推奨、optional/任意、または not recommended/非推奨)が示される。

A.1. DNS セキュリティ・アルゴリズム番号​

番号説明DNSSEC における使用状況備考
0予約(Reserved)—未割り当て
1RSA/MD5非推奨(NOT RECOMMENDED)[RFC3110] 参照
2Diffie-Hellman任意(OPTIONAL)[RFC2539] 参照
3DSA/SHA-1任意(OPTIONAL)[RFC2536] 参照
4ECC 用予約(Reserved)予約(Reserved)—
5RSA/SHA-1推奨(RECOMMENDED)[RFC3110] 参照
6DSA-NSEC3-SHA1任意(OPTIONAL)[RFC5157] 参照
7RSASHA1-NSEC3-SHA1推奨(RECOMMENDED)[RFC5157] 参照
8RSASHA256 用予約(Reserved)予約(Reserved)—
9RSASHA256推奨(RECOMMENDED)[RFC5702] 参照
10RSASHA512任意(OPTIONAL)[RFC5702] 参照
11ECC-GOST 用予約(Reserved)予約(Reserved)—
12ECC-GOST任意(OPTIONAL)[RFC5933] 参照
13ECDSAP256-SHA256推奨(RECOMMENDED)[RFC6605] 参照
14ECDSAP384-SHA384推奨(RECOMMENDED)[RFC6605] 参照
15-251未割り当て(Unassigned)—IETF 標準アクション(Standards Action)により割り当て
252間接(Indirect)任意(OPTIONAL)[RFC4034] 第 2 節参照
253秘密鍵(Private [explicit])任意(OPTIONAL)[RFC4034] 第 2 節参照
254秘密鍵(Private [OID])任意(OPTIONAL)[RFC4034] 第 2 節参照
255予約(Reserved)——

注:番号 8、11、および 15-251 の範囲の値は本書執筆時点では予約または未割り当てであった。後続の仕様([RFC5702]、[RFC5933]、[RFC6605]、[RFC5157] など)によりその一部が割り当てられている。本書執筆時点の状態を忠実に反映するため、上表では原文の予約/未割り当てのままとしている。

A.2. DNSSEC DS ダイジェスト型​

番号説明DNSSEC における使用状況
0予約(Reserved)—
1SHA-1推奨(RECOMMENDED)

関連章ナビゲーション: