7. IANA 考慮事項
本書は、本書で使用されているすべてのプロトコルパラメータがすでに先行する仕様によって割り当てられているため、新しい IANA 考慮事項を導入しない。しかしながら、DNSSEC の進化は長くやや複雑であったため、本節では DNSSEC に関連(またはかつて関連)する IANA レジストリおよびその他のプロトコルパラメータの現在の状態を記述することを試みる。
その他の IANA 考慮事項については [RFC4035] を参照。
DNS リソースレコード型:[RFC2535] は型 24、25、30 を SIG、KEY、NXT リソースレコードに割り当てた。[RFC3658] は DNS リソースレコード型 43 を DS リソースレコードに割り当てた。[RFC3755] は型 46、47、48 を RRSIG、NSEC、DNSKEY リソースレコードに割り当てた。[RFC3755] はまた、型 30(NXT)を廃止(obsolete)とし、型 24(SIG)および 25(KEY)の使用を、[RFC2931] で記述された "SIG(0)" トランザクション・セキュリティ・プロトコルおよび [RFC2930] で記述されたトランザクション KEY リソースレコードに限定した。
DNS セキュリティ・アルゴリズム番号:[RFC2535] は DNSSEC リソースレコードのアルゴリズムフィールドの番号付けのための IANA レジストリを作成し、値 1-4 および 252-255 を割り当てた。[RFC3110] は値 5 を割り当てた。[RFC3755] はこのレジストリを修正し、各エントリについて DNS セキュリティ拡張での使用状況(必須(mandated)、推奨(recommended)、任意(optional)、または使用してはならない(must not be used))を示すフラグ(flags)フィールドを追加した。各アルゴリズムエントリは、ゾーン署名(zone signing)、トランザクション・セキュリティ([RFC2931] 参照)、またはその両方に使用可能なアルゴリズムを参照してよい。値 6-251 は IETF 標準アクション(Standards Action、[RFC3755] 参照)により割り当て可能である。DNSSEC における使用状況を示す DNS セキュリティ・アルゴリズム番号エントリの完全なリストについては付録 A を参照。
[RFC3658] は DNSSEC DS ダイジェスト型(DS digest types)の IANA レジストリを作成し、値 0 を予約(Reserved)に、値 1 を SHA-1 に割り当てた。
KEY プロトコル値:[RFC2535] は KEY プロトコル値の IANA レジストリを作成したが、[RFC3445] は 3 以外のすべての値を予約(Reserved)に再割り当てし、この IANA レジストリを閉鎖した。レジストリは閉鎖されたままであり、すべての KEY および DNSKEY レコードはプロトコル・オクテット(protocol octet)の値を 3 にしなければならない。
KEY および DNSKEY RR のフラグビット:[RFC3755] は DNSSEC KEY および DNSKEY RR フラグビットの IANA レジストリを作成した。当初、このレジストリにはビット 7(ZONE ビット)およびビット 15(Secure Entry Point フラグ(SEP)ビット、[RFC3757] 参照)の割り当てのみが含まれていた。ビット 0-6 および 8-14 は、[RFC3755] で記述されたとおり、IETF 標準アクションにより割り当て可能である。
関連章ナビゲーション: