Skip to main content

6. RDAP Conformance

This section preserves the RFC text for RDAP RIR search, including rirSearch1, ips, autnums, ipSearchResults, autnumSearchResults, relation links, JSON examples, response behavior, reverse search, conformance, and IANA registrations.

Original RFC Text​

6.  RDAP Conformance

   A server that supports the functionality specified in this document
   MUST include additional string literals in the rdapConformance array
   of its responses, in accordance with the following:

   *  any response that includes an IP network basic search link, an IP
      network relation search link, or an IP network reverse search link
      includes the "rirSearch1" and "ips" literals;

   *  any response for an IP network basic search request, an IP network
      relation search request, or an IP network reverse search request
      includes the "rirSearch1", "ips", and "ipSearchResults" literals;

   *  any response that includes an ASN basic search link, an ASN
      relation search link, or an ASN reverse search link includes the
      "rirSearch1" and "autnums" literals;

   *  any response for an ASN basic search request, an ASN relation
      search request, or an ASN reverse search request includes the
      "rirSearch1", "autnums", and "autnumSearchResults" literals;

   *  any response that includes a domain relation search link includes
      the "rirSearch1" literal;

   *  any response for a domain relation search request includes the
      "rirSearch1" literal; and

   *  a response to a "/help" request includes the "rirSearch1", "ips",
      "ipSearchResults", "autnums", and "autnumSearchResults" literals.

   Although responses will generally not include all of the
   rdapConformance string literals defined in this document, that is not
   meant to imply that a server can support only a portion of the
   functionality defined in this document.

   The "ips", "autnums", "ipSearchResults", and "autnumSearchResults"
   extension identifiers are included here due to the requirements and
   recommendations set out in [RFC7480], [RFC9082], and [RFC9083].
   These requirements and recommendations are such that an RDAP
   extension identifier be used as a prefix in new path segments and
   JSON members introduced by the extension, and those strings are used
   as such as part of the basic searches defined in this document.
   Furthermore, using these strings as path segments helps to increase
   consistency among the basic searches for the core RDAP object
   classes.

   As with the other core object classes (entity, domain, and
   nameserver), other documents may define additional reverse searches
   with IP networks and ASNs as the searchable resource type by
   registering those in the IANA RDAP reverse search registries.
   Because a given extension identifier must correspond to a single
   extension, though, any document making use of IP networks or ASNs as
   the searchable resource type must also implement the functionality
   described in this document.

   The "1" in "rirSearch1" denotes that this is version 1 of the RIR
   search extension.  New versions of the RIR search extension will use
   different extension identifiers.  A version suffix is not used for
   the remaining identifiers defined by this document, partly because
   such a suffix would reduce consistency with the corresponding
   functionality for the other core object classes, and partly because
   it is very unlikely that the functionality associated with those
   identifiers will change.