メインコンテンツまでスキップ

4. セキュリティに関する考慮事項

UTF-8 は 1 文字の符号化に複数のオクテットを必要とすることが多いため, 国際化によってヘッダフィールド値 (一般に) およびメールアドレス (特に) が長くなる可能性がある. [RFC5322] で規定されているとおり, 各行は CRLF を除いて 998 オクテット以下でなければならない (MUST). 一方, 電子メールアドレスや local part を解析, 保存, または処理する MDA (Mail Delivery Agent) プロセスは, バッファオーバーフロー, アドレスの切り詰め, または記憶域割当量の超過を避けるよう特に注意しなければならない. また, 比較する際にはアドレスの全長を使用するよう注意しなければならない.

UTF-8 を使用して, 特定の表示文字または文字群と等価または類似のものを表現する方法は多数ある; これが引き起こす問題の詳細については [RFC3629] のセキュリティに関する考慮事項を参照されたい. これらの問題を最小限に抑えるために, セクション 3.1 に記載された正規化処理が推奨される.

UTF-8 ヘッダが Domain Keys Identified Mail (DKIM), S/MIME, OpenPGP などの電子メール署名システムに与えるセキュリティ上の影響は, [RFC6530] のセクション 14 で論じられている.

ユーザが非 ASCII のメールボックスアドレスと ASCII のメールボックスアドレスの両方を持っている場合, そのユーザを識別するデジタル証明書は, その識別情報に両方のアドレスを含むことがある. 単一の証明書に複数の電子メールアドレスを識別情報として持つことは, PKIX (Public Key Infrastructure using X.509) [RFC5280] および OpenPGP [RFC3156] で既にサポートされているが, この文脈でアドレスに UTF-8 を導入することに関連して, ユーザインタフェース上の問題が生じる可能性がある.