7. Considerazioni IANA
Il presente documento non introduce nuove considerazioni IANA, poiché tutti i parametri di protocollo utilizzati in questo documento sono già stati assegnati da specifiche precedenti. Tuttavia, dato che l'evoluzione di DNSSEC è stata lunga e alquanto complessa, questa sezione tenta di descrivere lo stato attuale dei registri IANA e degli altri parametri di protocollo associati (o un tempo associati) a DNSSEC.
Per ulteriori considerazioni IANA, si veda [RFC4035].
Tipi di resource record DNS: [RFC2535] ha assegnato i tipi 24, 25 e 30 ai resource record SIG, KEY e NXT. [RFC3658] ha assegnato il tipo 43 DNS al resource record DS. [RFC3755] ha assegnato i tipi 46, 47 e 48 ai resource record RRSIG, NSEC e DNSKEY. [RFC3755] ha inoltre contrassegnato il tipo 30 (NXT) come obsoleto (obsolete) e ha limitato l'uso dei tipi 24 (SIG) e 25 (KEY) al protocollo di sicurezza delle transazioni "SIG(0)" descritto in [RFC2931] e al resource record di chiave di transazione descritto in [RFC2930].
Numeri di algoritmo di sicurezza DNS: [RFC2535] ha creato il registro IANA per la numerazione dei campi algoritmo dei resource record DNSSEC e ha assegnato i valori 1-4 nonché 252-255. [RFC3110] ha assegnato il valore 5. [RFC3755] ha modificato tale registro aggiungendo un campo di flag (flags) che indica, per ciascuna voce, lo stato d'uso nelle estensioni di sicurezza DNS: obbligatorio (mandated), raccomandato (recommended), opzionale (optional) o da non utilizzare (must not be used). Ciascuna voce di algoritmo può fare riferimento a un algoritmo utilizzabile per la firma di zona (zone signing), la sicurezza delle transazioni (vedi [RFC2931]) o entrambe. I valori 6-251 possono essere assegnati tramite un'azione standard IETF (Standards Action, vedi [RFC3755]). Per l'elenco completo delle voci del numero di algoritmo di sicurezza DNS e del loro stato d'uso in DNSSEC, si veda l'appendice A.
[RFC3658] ha creato il registro IANA dei tipi di digest DS DNSSEC (DS digest types) e ha assegnato il valore 0 a riservato (Reserved) e il valore 1 a SHA-1.
Valori di protocollo KEY: [RFC2535] ha creato il registro IANA dei valori di protocollo KEY, ma [RFC3445] ha riassegnato tutti i valori diversi da 3 come riservati (Reserved) e ha chiuso tale registro IANA. Il registro rimane chiuso e tutti i record KEY e DNSKEY devono avere il valore dell'ottetto di protocollo (protocol octet) impostato a 3.
Bit di flag nei resource record KEY e DNSKEY: [RFC3755] ha creato il registro IANA dei bit di flag (flags) dei resource record DNSSEC KEY e DNSKEY. Inizialmente, tale registro conteneva solo l'assegnazione dei bit 7 (bit ZONE) e 15 (bit Secure Entry Point (SEP); vedi [RFC3757]). I bit da 0 a 6 e da 8 a 14 possono essere assegnati tramite un'azione standard IETF, come descritto in [RFC3755].
Navigazione tra sezioni:
- Precedente: 6. Forma canonica e ordinamento dei resource record
- Successivo: 8. Considerazioni sulla sicurezza