Passa al contenuto principale

RFC 4034

Informazioni sul documento​

  • Numero RFC: 4034
  • Titolo: Resource Records for the DNS Security Extensions (Resource record per le estensioni di sicurezza DNS)
  • Autori: R. Arends, R. Austein, M. Larson, D. Massey, S. Rose
  • Data di pubblicazione: marzo 2005
  • Livello di maturità: Proposed Standard (standard proposto)
  • Flusso: Internet Engineering Task Force (IETF)
  • Stato del verbale: Stato di questo memorandum
  • Lingua di pubblicazione: inglese

Stato di questo memorandum​

Il presente memorandum registra una specifica per la comunità Internet e richiede discussione e suggerimenti per il miglioramento. Si prega di consultare la versione corrente delle "Norme ufficiali dei protocolli Internet" (STD 1) per conoscere lo stato normativo e lo stato di avanzamento di questo protocollo. La distribuzione di questo memorandum non è soggetta a restrizioni.

Copyright (C) 2005 The Internet Society. Tutti i diritti riservati.

Il presente documento è soggetto alle disposizioni della BCP 78 e alle disposizioni legali relative all'IETF Trust, come spiegato di seguito. Il presente documento è protetto dalle copyright applicabili e, salvo diversa indicazione, gli autori conservano tutti i loro diritti.

Sintesi​

Il presente documento è il terzo di una serie di documenti che definiscono le estensioni di sicurezza del Domain Name System (DNSSEC). [RFC4033] descrive i requisiti di DNSSEC nonché la protezione offerta da tali estensioni. Il presente documento specifica i codici di tipo, i formati e la semantica dei quattro nuovi resource record utilizzati da DNSSEC. [RFC4035] descrive come tali record vengano utilizzati congiuntamente al protocollo DNS; in altri termini, descrive come i resource record definiti in questo documento vengano usati per fornire autenticazione e integrità dei dati DNS.

DNSSEC è un complemento alle specifiche DNS esistenti. Esso mantiene ed estende il protocollo DNS standard. DNSSEC protegge i dati DNS trasmettendo firme crittografiche tra i processi che elaborano i dati DNS. DNSSEC non modifica il modo in cui i messaggi DNS esistenti vengono inviati e ricevuti, il formato dei file di zona né l'analisi sintattica dei messaggi o dei file di zona.

DNSSEC è definito dai tre documenti [RFC4033], il presente documento ([RFC4034]) e [RFC4035].

Indice​

RFC correlati​


Navigazione tra sezioni: