RFC 4034
ドキュメント情報
- RFC 番号: 4034
- タイトル: Resource Records for the DNS Security Extensions(DNS セキュリティ拡張のリソースレコード)
- 著者: R. Arends、R. Austein、M. Larson、D. Massey、S. Rose
- 発行日: 2005 年 3 月
- 成熟度レベル: 提案標準(Proposed Standard)
- ストリーム: インターネット技術特別調査委員会(IETF)
- 議事録の状態: 本メモの状態
- 出版言語: 英語
本メモの状態
本メモはインターネットコミュニティへの仕様を記録したものであり、改善のための議論および提案を求める。現在の「インターネット公式プロトコル標準」(STD 1)を参照して、このプロトコルの標準化状態および進捗を確認されたい。本メモの配布は制限されない。
著作権表示
Copyright (C) 2005 インターネットソサエティ(The Internet Society)。All Rights Reserved.
本書は BCP 78 および IETF トラストに関する法的規定の対象となり、詳細は以下のとおりである。本書は該当する著作権によって保護されており、特記がない限り、各著者はすべての権利を留保する。
要約
本書は、ドメインネームシステム・セキュリティ拡張(DNSSEC)を定義する一連の文書のうちの第 3 部である。[RFC4033] は DNSSEC の要件およびこれらの拡張によって提供される保護を記述している。本書は、DNSSEC によって使用される 4 種類の新しいリソースレコードの型コード、フォーマット、およびセマンティクスを規定する。[RFC4035] は、これらのレコードが DNS プロトコルとどのように組み合わせて使用されるか、すなわち本書で定義されたリソースレコードを使用して DNS データに真正性(authentication)およびデータ完全性(integrity)をどのように提供するかを記述している。
DNSSEC は既存の DNS 仕様に対する補足である。DNSSEC は標準 DNS プロトコルを維持しつつ拡張する。DNSSEC は、DNS データを処理するプロセス間で暗号署名を伝達することによって DNS データを保護する。DNSSEC は、既存の DNS メッセージの送受信方法、ゾーンファイルのフォーマット、メッセージの構文解析、またはゾーンファイルの解析方法を変更しない。
DNSSEC は [RFC4033]、本書([RFC4034])、および [RFC4035] の 3 文書によって定義される。
目次
- 1. 概要
- 2. DNSKEY リソースレコード
- 3. RRSIG リソースレコード
- 4. DS リソースレコード
- 5. NSEC リソースレコード
- 6. リソースレコードの正規形式と順序
- 7. IANA 考慮事項
- 8. セキュリティ考慮事項
- 9. 謝辞
- 10. 参考文献
- 付録 A. DNSSEC アルゴリズムおよびダイジェスト型
- 付録 B. キータグ計算
関連 RFC
- RFC 4033 — DNS Security Introduction and Requirements
- RFC 4034 — Resource Records for the DNS Security Extensions(本書)
- RFC 4035 — Protocol Modifications for the DNS Security Extensions
関連章ナビゲーション:
- 次へ:1. 概要