Aller au contenu principal

RFC 4034

Informations sur le document​

  • Numéro RFC : 4034
  • Titre : Resource Records for the DNS Security Extensions (Enregistrements de ressources pour les extensions de sécurité DNS)
  • Auteurs : R. Arends, R. Austein, M. Larson, D. Massey, S. Rose
  • Date de publication : mars 2005
  • Niveau de maturité : Standard proposé (Proposed Standard)
  • Flux : Internet Engineering Task Force (IETF)
  • État du procès-verbal : État de ce mémorandum
  • Langue de publication : anglais

État de ce mémorandum​

Le présent mémorandum consigne une spécification pour la communauté Internet et demande des commentaires et des suggestions d'amélioration. Veuillez consulter la version actuelle des « Normes officielles de protocole Internet » (STD 1) pour connaître l'état normalisé et la progression de ce protocole. La distribution de ce mémorandum n'est soumise à aucune restriction.

Avis de droit d'auteur​

Copyright (C) 2005 The Internet Society. Tous droits réservés.

Le présent document est soumis aux dispositions de la BCP 78 et aux dispositions juridiques relatives au IETF Trust, comme expliqué ci-dessous. Le présent document est protégé par les droits d'auteur applicables, et sauf indication contraire, les auteurs conservent tous leurs droits.

Résumé​

Ce document est le troisième d'une série de documents définissant les extensions de sécurité du système de noms de domaine (DNSSEC). [RFC4033] décrit les exigences de DNSSEC ainsi que la protection offerte par ces extensions. Ce document spécifie les codes de type, les formats et la sémantique des quatre nouveaux enregistrements de ressources utilisés par DNSSEC. [RFC4035] décrit comment ces enregistrements sont utilisés conjointement avec le protocole DNS ; autrement dit, comment les enregistrements de ressources définis dans ce document sont utilisés pour fournir une authentification et une intégrité des données DNS.

DNSSEC est un complément aux spécifications DNS existantes. Il préserve et étend le protocole DNS standard. DNSSEC protège les données DNS en transmettant des signatures cryptographiques entre les processus qui traitent les données DNS. DNSSEC ne modifie pas la façon dont les messages DNS existants sont envoyés et reçus, le format des fichiers de zone, ni l'analyse syntaxique des messages ou des fichiers de zone.

DNSSEC est défini par les trois documents [RFC4033], ce document ([RFC4034]) et [RFC4035].

Table des matières​

RFC associés​


Navigation entre sections :