12. Considerazioni IANA (IANA Considerations)
and IMAP2bis", RFC 1732, December 1994.
[IMAP-OBSOLETE] Crispin, M., "Internet Message Access Protocol - Obsolete Syntax", RFC 2062, December 1996.
[IMAP2] Crispin, M., "Interactive Mail Access Protocol - Version 2", RFC 1176, August 1990.
[RFC-822] Crocker, D., "Standard for the Format of ARPA Internet Text Messages", STD 11, RFC 822, August 1982.
[RFC-821] Postel, J., "Simple Mail Transfer Protocol", STD 10, RFC 821, August 1982.
B. Modifiche rispetto a RFC 2060 (Changes from RFC 2060)
-
Chiarimento della descrizione degli identificatori univoci (unique identifiers) e della loro semantica.
-
Correzione della descrizione di SELECT per chiarire che UIDVALIDITY è richiesto nelle risposte SELECT ed EXAMINE.
-
Aggiunto un esempio di una ricerca (search) fallita.
-
Correzione di store-att-flags: "
#flag" dovrebbe essere "1#flag". -
Le regole per search e section sono state formulate in modo più chiaro.
-
Corretto l'esempio di STORE.
-
Corretto l'errore di battitura "BASE645".
-
Rimossa una parentesi di chiusura superflua nell'esempio di un messaggio a due parti con testo e allegato BASE64.
RFC 3501 IMAPv4 March 2003
-
Rimossa la risposta "MAILBOX" obsoleta da mailbox-data.
-
Rimosso uno fuorviante "
<" nella regola per mailbox-data. -
Aggiunto CRLF a continue-req.
-
Escluso esplicitamente "
]" dall'atom in resp-text-code. -
Chiarito che client e server dovrebbero essere vincolati più rigorosamente alla sintassi del protocollo.
-
In 5.2 evidenziato che EXISTS non può essere usato per ridurre una mailbox.
-
Aggiunto NEWNAME a resp-text-code.
-
Chiarito che la stringa vuota e non NIL è usata come argomento per LIST.
-
Chiarito che NIL può essere restituito come separatore di gerarchia per l'argomento del nome di mailbox vuoto, se lo spazio dei nomi della mailbox è piatto.
-
Chiarito che per addr-mailbox e addr-name viene rimosso il quoting di [RFC-2822].
-
Aggiornato il riferimento a UTF-7.
-
Corretto l'esempio in 6.3.11.
-
Chiarito che gli UID inesistenti vengono ignorati.
-
Aggiornato il riferimento a DISPOSITION.
-
Ampliato il diagramma di stato.
-
Chiarito che le risposte fetch parziali si trovano solo in