Passa al contenuto principale

Appendice B. Modifiche rispetto a RFC 2060 (Appendix B. Changes from RFC 2060)

  1. Chiarito che i comandi che interrompono il pipelining dei comandi devono attendere una risposta di risultato con tag.

  2. Chiarito che EXAMINE non influisce su \Recent.

RFC 3501 IMAPv4 March 2003

  1. Resa coerente la descrizione della struttura MIME.

  2. Chiarito che le ricerche per data (date searches) ignorano l'ora e il fuso orario della data INTERNALDATE o dell'intestazione Date. In altre parole "ON 13-APR-2000" indica messaggi con un testo INTERNALDATE che inizia con "13-APR-2000", anche se la differenza di fuso orario rispetto al fuso orario locale è sufficiente a spostare tale INTERNALDATE al giorno precedente o successivo.

  3. Chiarito (nella trattazione degli UID) che i messaggi sono immutabili (immutable).

  4. Chiarito che i fetch di intestazione non aggiungono una riga vuota quando non ve n'è una nel messaggio [RFC-2822].

  5. Aggiunto un esempio di ricerca CHARSET.

  6. In SEARCH chiarito che le parole chiave (keywords) sono un tipo di flag.

  7. Chiarita la natura vincolante delle risposte di dati SELECT.

  8. Aggiunto il codice di risposta CAPABILITY opzionale nella risposta iniziale OK o PREAUTH.

  9. Aggiunta nota che il server può inviare una risposta CAPABILITY non taggata come parte delle risposte a AUTHENTICATE e LOGIN.

  10. Rimossa l'affermazione che sia inutile emettere un comando CAPABILITY più di una volta entro una connessione. Ciò non è più vero.

  11. Chiarito che un EXPUNGE non taggato riduce il numero di messaggi nella mailbox.

  12. Corretta la definizione di "body" (la concatenazione lega più strettamente dell'alternazione).

  13. Aggiunta una nuova sezione "Special Notes to Implementors" con riferimento a [IMAP-IMPLEMENTATION].

  14. Chiarito che una risposta CAPABILITY non taggata a un comando AUTHENTICATE dovrebbe essere inviata solo se non è stato negoziato alcun livello di sicurezza (security layer).

  15. Modificata la definizione di atom per escludere "]". Aggiornato astring in modo da contenere "]" per compatibilità con il passato. Rimosso resp-text-atom.

  16. Rimosso NEWNAME. Non può funzionare poiché i nomi di mailbox possono essere letterali e contenere "]". La funzionalità può essere affrontata tramite i referral (referrals).

RFC 3501 IMAPv4 March 2003

  1. Spostata la giustificazione per UTF-7 modificato per ottenere un flusso di paragrafi più logico.

  2. Chiarita l'unicità degli UID con l'uso di MUST.

  3. Nota che i client dovrebbero leggere i dati di risposta fino alla chiusura della connessione anziché chiudere immediatamente al BYE.

  4. Cambiati i riferimenti RFC-822 in RFC-2822.

  5. Chiarito che dovrebbe essere seguito RFC-2822 anziché RFC-822.

  6. Modificata la raccomandazione per le funzionalità opzionali automatiche in LOGIN e AUTHENTICATE per usare il codice di risposta CAPABILITY nella risposta OK con tag. Ciò è più interoperabile di una risposta CAPABILITY non taggata non richiesta.

  7. STARTTLS e AUTH=PLAIN sono obbligatori da implementare; aggiunte raccomandazioni per altri meccanismi [SASL].

  8. Chiarito che una "connessione" (a differenza di "server" o "comando") si trova in uno dei quattro stati.

  9. Chiarito che un comando fallito o rifiutato non modifica lo stato.

  10. Suddivisi i riferimenti tra normativi e informativi.

  11. Discusse le problematiche di errore di autenticazione nella sezione sicurezza.

  12. Chiarito che un elemento dati non è necessariamente di un solo tipo di dati.

  13. Chiarito che gli intervalli di sequenza (sequence ranges) sono indipendenti dall'ordine.

  14. Modificato un esempio per chiarire che gli shift ridondanti in Modified-UTF7 non possono essere semplicemente corretti omettendo lo shift. L'intera stringa deve essere ricalcolata.

  15. Modificata la definizione della struttura di busta poiché [RFC-2822] usa "envelope" per indicare la busta [SMTP] e non i dati di busta che compaiono nell'intestazione [RFC-2822].

  16. Sviluppata la distinzione tra dati di risposta RFC822.HEADER e BODY[HEADER].

  17. Chiarita la semantica di stato di LOGOUT, modificata l'arte ASCII.

  18. Modifiche di sicurezza per conformarsi ai requisiti IESG.

RFC 3501 IMAPv4 March 2003

  1. Aggiunta la definizione di Body-URI.

  2. Suddivisa la definizione di intervallo di sequenza in tre regole, con descrizioni riscritte per ciascuna.

  3. Spostati qui STARTTLS e LOGINDISABLED da [IMAP-TLS].

  4. Aggiunta la sezione "Considerazioni IANA".

  5. Chiarite le ipotesi valide del client per i nuovi UID rispetto a UIDNEXT.

  6. Chiarito che le modifiche a permanentflags riguardano sia le sessioni simultanee sia quelle successive.

  7. Chiarito che lo stato autenticato può essere raggiunto tramite il comando CLOSE.

  8. Sottolineato che SELECT ed EXAMINE sono le eccezioni alla regola che un comando fallito non modifica lo stato.

  9. Chiarito che i messaggi appena accodati hanno il flag Recent impostato.

  10. Chiarito che i messaggi appena copiati DOVREBBERO avere il flag Recent impostato.

  11. Chiarito che i comandi UID restituiscono sempre l'UID nelle risposte FETCH.

C. Indice delle parole chiave (Key Word Index)

   +FLAGS \<flag list> (store command data item) ...............   59
+FLAGS.SILENT \<flag list> (store command data item) ........ 59
-FLAGS \<flag list> (store command data item) ............... 59
-FLAGS.SILENT \<flag list> (store command data item) ........ 59
ALERT (response code) ...................................... 64
ALL (fetch item) ........................................... 55
ALL (search key) ........................................... 50
ANSWERED (search key) ...................................... 50
APPEND (command) ........................................... 45
AUTHENTICATE (command) ..................................... 27
BAD (response) ............................................. 66
BADCHARSET (response code) ................................. 64
BCC \<string> (search key) .................................. 51
BEFORE \<date> (search key) ................................. 51
BODY (fetch item) .......................................... 55
BODY (fetch result) ........................................ 73
BODY \<string> (search key) ................................. 51

RFC 3501 IMAPv4 March 2003

   BODY.PEEK[\<section>]\&lt;\&lt;partial>> (fetch item) ...............   57
   BODYSTRUCTURE (fetch item) .................................   57
   BODYSTRUCTURE (fetch result) ...............................   74
   BODY[\<section>]\&lt;\&lt;origin octet>> (fetch result) .............   74
   BODY[\<section>]\&lt;\&lt;partial>> (fetch item) ....................   55
   BYE (response) .............................................   67
   Body Structure (message attribute) .........................   12
   CAPABILITY (command) .......................................   24
   CAPABILITY (response code) .................................   64
   CAPABILITY (response) ......................................   68
   CC \&lt;string> (search key) ...................................   51
   CHECK (command) ............................................   47
   CLOSE (command) ............................................   48
   COPY (command) .............................................   59
   CREATE (command) ...........................................   34
   DELETE (command) ...........................................   35
   DELETED (search key) .......................................   51
   DRAFT (search key) .........................................   51
   ENVELOPE (fetch item) ......................................   57
   ENVELOPE (fetch result) ....................................   77
   EXAMINE (command) ..........................................   33
   EXISTS (response) ..........................................   71
   EXPUNGE (command) ..........................................   48
   EXPUNGE (response) .........................................   72
   Envelope Structure (message attribute) .....................   12
   FAST (fetch item) ..........................................   55
   FETCH (command) ............................................   54
   FETCH (response) ...........................................   73
   FLAGGED (search key) .......................................   51
   FLAGS (fetch item) .........................................   57
   FLAGS (fetch result) .......................................   78
   FLAGS (response) ...........................................   71
   FLAGS \&lt;flag list> (store command data item) ................   59
   FLAGS.SILENT \&lt;flag list> (store command data item) .........   59
   FROM \&lt;string> (search key) .................................   51
   FULL (fetch item) ..........................................   55
   Flags (message attribute) ..................................   11
   HEADER (part specifier) ....................................   55
   HEADER `&lt;field-name>` \&lt;string> (search key) ..................   51
   HEADER.FIELDS `&lt;header-list>` (part specifier) ...............   55
   HEADER.FIELDS.NOT `&lt;header-list>` (part specifier) ...........   55
   INTERNALDATE (fetch item) ..................................   57
   INTERNALDATE (fetch result) ................................   78
   Internal Date (message attribute) ..........................   12
   KEYWORD \&lt;flag> (search key) ................................   51
   Keyword (type of flag) .....................................   11
   LARGER \&lt;n> (search key) ....................................   51
   LIST (command) .............................................   40

RFC 3501 IMAPv4 March 2003

   LIST (response) ............................................   69
   LOGIN (command) ............................................   30
   LOGOUT (command) ...........................................   25
   LSUB (command) .............................................   43
   LSUB (response) ............................................   70
   MAY (specification requirement term) .......................    4
   MESSAGES (status item) .....................................   45
   MIME (part specifier) ......................................   56
   MUST (specification requirement term) ......................    4
   MUST NOT (specification requirement term) ..................    4
   Message Sequence Number (message attribute) ................   10
   NEW (search key) ...........................................   51
   NO (response) ..............................................   66
   NOOP (command) .............................................   25
   NOT `&lt;search-key>` (search key) ..............................   52
   OK (response) ..............................................   65
   OLD (search key) ...........................................   52
   ON \&lt;date> (search key) .....................................   52
   OPTIONAL (specification requirement term) ..................    4
   OR `&lt;search-key1>` `&lt;search-key2>` (search key) ................   52
   PARSE (response code) ......................................   64
   PERMANENTFLAGS (response code) .............................   64
   PREAUTH (response) .........................................   67
   Permanent Flag (class of flag) .............................   12
   READ-ONLY (response code) ..................................   65
   READ-WRITE (response code) .................................   65
   RECENT (response) ..........................................   72
   RECENT (search key) ........................................   52
   RECENT (status item) .......................................   45
   RENAME (command) ...........................................   37
   REQUIRED (specification requirement term) ..................    4
   RFC822 (fetch item) ........................................   57
   RFC822 (fetch result) ......................................   78
   RFC822.HEADER (fetch item) .................................   57
   RFC822.HEADER (fetch result) ...............................   78
   RFC822.SIZE (fetch item) ...................................   57
   RFC822.SIZE (fetch result) .................................   78
   RFC822.TEXT (fetch item) ...................................   58
   RFC822.TEXT (fetch result) .................................   79
   SEARCH (command) ...........................................   49
   SEARCH (response) ..........................................   71
   SEEN (search key) ..........................................   52