メインコンテンツまでスキップ

Appendix B. Changes from RFC 2060

  1. コマンドパイプラインを破るコマンドは, 完了結果レスポンスを待機しなければならないことを明確化した.

  2. EXAMINE は \Recent に影響しないことを明確化した.

RFC 3501 IMAPv4 March 2003

  1. MIME 構造の記述を一貫性のあるものにした.

  2. 日付検索は INTERNALDATE または Date: ヘッダーの時刻およびタイムゾーンを無視することを明確化した. 言い換えれば, "ON 13-APR-2000" は, ローカルタイムゾーンからの差がその INTERNALDATE を前日または翌日に移動するのに十分であっても, "13-APR-2000" で始まる INTERNALDATE テキストを持つメッセージを意味する.

  3. ヘッダーフェッチは, [RFC-2822] メッセージ内に存在しない場合は空行を追加しないことを明確化した.

  4. (UID の議論において) メッセージは不変であることを明確化した.

  5. CHARSET 検索の例を追加した.

  6. キーワードはフラグの一種であることを SEARCH において明確化した.

  7. SELECT データレスポンスの必須性を明確化した.

  8. 初期の OK または PREAUTH にオプションの CAPABILITY レスポンスコードを追加した.

  9. サーバーが AUTHENTICATE および LOGIN へのレスポンスの一部として, タグなし CAPABILITY コマンドを送信できるという注記を追加した.

  10. 接続内で CAPABILITY コマンドを複数回発行する必要がないという記述を削除した. その記述はもはや真ではない.

  11. タグなし EXPUNGE はメールボックス内のメッセージ数を減らすことを明確化した.

  12. "body" の定義を修正した (連結は選択よりも強く結合する).

  13. [IMAP-IMPLEMENTATION] への参照を含む, 新しい "実装者への特記事項 (Special Notes to Implementors)" セクションを追加した.

  14. タグなし CAPABILITY レスポンスを AUTHENTICATE コマンドに対して行うのは, セキュリティ層が交渉されなかった場合にのみとすべきであることを明確化した.

  15. "]" を除外するように atom の定義を変更した. 過去との互換性のために "]" を含むように astring を更新した. resp-text-atom を削除した.

  16. NEWNAME を削除した. メールボックス名はリテラルであり "]" を含み得るため, それは機能しない. 機能性はリフェラルを通じて対処できる.

RFC 3501 IMAPv4 March 2003

  1. より論理的な段落の流れを持たせるために, 修正 UTF-7 の根拠を移動した.

  2. UID 一意性の保証を MUST を用いて明確化した.

  3. クライアントは BYE で直ちに接続を閉じるのではなく, 接続が閉じられるまでレスポンスデータを読み続けるべきであると注記した.

  4. RFC-822 への参照を RFC-2822 に変更した.

  5. RFC-822 の代わりに RFC-2822 に従うべきであることを明確化した.

  6. LOGIN および AUTHENTICATE におけるオプションの自動機能の推奨を, タグ付き OK の CAPABILITY レスポンスコードを使用するように変更した. これは, 一方的なタグなし CAPABILITY レスポンスよりも相互運用性が高い.

  7. STARTTLS および AUTH=PLAIN は実装に必須であり, 他の [SASL] メカニズムへの推奨を追加した.

  8. 「接続」 (「サーバー」や「コマンド」と対照的) は 4 つの状態のいずれかにあることを明確化した.

  9. 失敗または拒否されたコマンドは状態を変更しないことを明確化した.

  10. 参照を規範的と参考的とに分割した.

  11. セキュリティセクションで認証失敗の問題について論じた.

  12. データ項目が必ずしも 1 つのデータ型のみを持つとは限らないことを明確化した.

  13. シーケンス範囲は順序に依存しないことを明確化した.

  14. 余分なシフトを単にシフトを省略するだけでは修正できないことを明確化するために例を変更した. 文字列全体を再計算しなければならない.

  15. [RFC-2822] が [SMTP] エンベロープを指しており, [RFC-2822] ヘッダーに現れるエンベロープデータではないため, エンベロープ構造の定義を変更した.

  16. RFC822.HEADER レスポンスデータと BODY[HEADER] の違いを拡張した.

  17. ログアウト状態の意味論を明確化し, ASCII 図を変更した.

  18. IESG の要件に準拠するためのセキュリティ変更.

RFC 3501 IMAPv4 March 2003

  1. ボディ URI の定義を追加した.

  2. シーケンス範囲の定義を 3 つの規則に分割し, それぞれの記述を書き直した.

  3. STARTTLS および LOGINDISABLED を [IMAP-TLS] からここに移動した.

  4. IANA に関する考慮事項のセクションを追加した.

  5. 新しいメッセージの UID と UIDNEXT に関する有効なクライアントの想定を明確化した.

  6. permanentflags への変更は, 後続のセッションだけでなく並行セッションにも影響することを明確化した.

  7. 認証済み状態には CLOSE コマンドによって入ることができることを明確化した.

  8. SELECT および EXAMINE は, 失敗するコマンドが状態を変更しないという規則の例外であることを強調した.

  9. 新しく追加されたメッセージには Recent フラグが設定されることを明確化した.

  10. 新しくコピーされたメッセージは Recent フラグを設定すべきである (SHOULD) ことを明確化した.

  11. UID コマンドは常に FETCH レスポンス内で UID を返すことを明確化した.

C. Key Word Index

   +FLAGS \<flag list> (store command data item) ...............   59
+FLAGS.SILENT \<flag list> (store command data item) ........ 59
-FLAGS \<flag list> (store command data item) ............... 59
-FLAGS.SILENT \<flag list> (store command data item) ........ 59
ALERT (response code) ...................................... 64
ALL (fetch item) ........................................... 55
ALL (search key) ........................................... 50
ANSWERED (search key) ...................................... 50
APPEND (command) ........................................... 45
AUTHENTICATE (command) ..................................... 27
BAD (response) ............................................. 66
BADCHARSET (response code) ................................. 64
BCC \<string> (search key) .................................. 51
BEFORE \<date> (search key) ................................. 51
BODY (fetch item) .......................................... 55
BODY (fetch result) ........................................ 73
BODY \<string> (search key) ................................. 51

RFC 3501 IMAPv4 March 2003

   BODY.PEEK[\<section>]\&lt;\&lt;partial>> (fetch item) ...............   57
   BODYSTRUCTURE (fetch item) .................................   57
   BODYSTRUCTURE (fetch result) ...............................   74
   BODY[\<section>]\&lt;\&lt;origin octet>> (fetch result) .............   74
   BODY[\<section>]\&lt;\&lt;partial>> (fetch item) ....................   55
   BYE (response) .............................................   67
   Body Structure (message attribute) .........................   12
   CAPABILITY (command) .......................................   24
   CAPABILITY (response code) .................................   64
   CAPABILITY (response) ......................................   70
   CC \&lt;string> (search key) ...................................   51
   CHECK (command) ............................................   47
   CLOSE (command) ............................................   48
   COPY (command) .............................................   59
   CREATE (command) ...........................................   34
   DELETE (command) ...........................................   35
   DELETED (search key) .......................................   51
   DRAFT (search key) .........................................   51
   ENVELOPE (fetch item) ......................................   57
   ENVELOPE (fetch result) ....................................   77
   EXAMINE (command) ..........................................   33
   EXISTS (response) ..........................................   71
   EXPUNGE (command) ..........................................   48
   EXPUNGE (response) .........................................   72
   Envelope Structure (message attribute) .....................   12
   FAST (fetch item) ..........................................   55
   FETCH (command) ............................................   54
   FETCH (response) ...........................................   73
   FLAGGED (search key) .......................................   51
   FLAGS (fetch item) .........................................   57
   FLAGS (fetch result) .......................................   78
   FLAGS (response) ...........................................   71
   FLAGS \&lt;flag list> (store command data item) ................   59
   FLAGS.SILENT \&lt;flag list> (store command data item) .........   59
   FROM \&lt;string> (search key) .................................   51
   FULL (fetch item) ..........................................   55
   Flags (message attribute) ..................................   11
   HEADER (part specifier) ....................................   55
   HEADER `&lt;field-name>` \&lt;string> (search key) ..................   51
   HEADER.FIELDS `&lt;header-list>` (part specifier) ...............   55
   HEADER.FIELDS.NOT `&lt;header-list>` (part specifier) ...........   55
   INTERNALDATE (fetch item) ..................................   57
   INTERNALDATE (fetch result) ................................   78
   Internal Date (message attribute) ..........................   12
   KEYWORD \&lt;flag> (search key) ................................   51
   Keyword (type of flag) .....................................   11
   LARGER \&lt;n> (search key) ....................................   51
   LIST (command) .............................................   40

RFC 3501 IMAPv4 March 2003

   LIST (response) ............................................   69
   LOGIN (command) ............................................   30
   LOGOUT (command) ...........................................   25
   LSUB (command) .............................................   43
   LSUB (response) ............................................   70
   MAY (specification requirement term) .......................    4
   MESSAGES (status item) .....................................   45
   MIME (part specifier) ......................................   56
   MUST (specification requirement term) ......................    4
   MUST NOT (specification requirement term) ..................    4
   Message Sequence Number (message attribute) ................   10
   NEW (search key) ...........................................   51
   NO (response) ..............................................   66
   NOOP (command) .............................................   25
   NOT `&lt;search-key>` (search key) ..............................   52
   OK (response) ..............................................   65
   OLD (search key) ...........................................   52
   ON \&lt;date> (search key) .....................................   52
   OPTIONAL (specification requirement term) ..................    4
   OR `&lt;search-key1>` `&lt;search-key2>` (search key) ................   52
   PARSE (response code) ......................................   64
   PERMANENTFLAGS (response code) .............................   64
   PREAUTH (response) .........................................   67
   Permanent Flag (class of flag) .............................   12
   READ-ONLY (response code) ..................................   65
   READ-WRITE (response code) .................................   65
   RECENT (response) ..........................................   72
   RECENT (search key) ........................................   52
   RECENT (status item) .......................................   45
   RENAME (command) ...........................................   37
   REQUIRED (specification requirement term) ..................    4
   RFC822 (fetch item) ........................................   57
   RFC822 (fetch result) ......................................   78
   RFC822.HEADER (fetch item) .................................   57
   RFC822.HEADER (fetch result) ...............................   78
   RFC822.SIZE (fetch item) ...................................   57
   RFC822.SIZE (fetch result) .................................   78
   RFC822.TEXT (fetch item) ...................................   58
   RFC822.TEXT (fetch result) .................................   79
   SEARCH (command) ...........................................   49
   SEARCH (response) ..........................................   71
   SEEN (search key) ..........................................   52