Aller au contenu principal

3. Architecture

Cette section décrit le modèle d'architecture pour les routeurs de bordure client IPv6 et le compare avec l'architecture IPv4 actuelle.

3.1. Architecture actuelle du réseau utilisateur final IPv4​

Un réseau utilisateur final prendra probablement en charge à la fois IPv4 et IPv6. Il n'est pas prévu qu'un utilisateur final modifie sa topologie de réseau existante avec l'introduction d'IPv6. Il existe quelques différences dans la façon dont IPv6 fonctionne et est provisionné ; ces différences ont des implications pour l'architecture du réseau. Un réseau utilisateur final IPv4 typique se compose d'un routeur « plug and play » avec une fonctionnalité NAT et un seul lien derrière lui, connecté au réseau du fournisseur de services.

Un déploiement NAT IPv4 typique bloque par défaut toutes les connexions entrantes. L'ouverture de ports est généralement autorisée en utilisant un dispositif de passerelle Internet Universal Plug and Play (UPnP IGD - Universal Plug and Play Internet Gateway Device) [UPnP-IGD] ou un autre protocole de contrôle de pare-feu.

Une autre conséquence de l'utilisation de l'espace d'adressage privé dans le réseau utilisateur final est qu'il fournit un adressage stable ; c'est-à-dire qu'il ne change jamais même lorsque vous changez de fournisseur de services, et les adresses sont toujours présentes même lorsque l'interface WAN est arrêtée ou que le routeur de bordure client n'a pas encore été provisionné.

De nombreux routeurs existants prennent en charge le routage dynamique (qui apprend les routes d'autres routeurs), et les utilisateurs finaux avancés peuvent construire des réseaux arbitraires et complexes en utilisant une configuration manuelle de préfixes d'adresses combinée avec un protocole de routage dynamique.

3.2. Architecture du réseau utilisateur final IPv6​

L'architecture du réseau utilisateur final pour IPv6 devrait fournir des capacités et des fonctionnalités équivalentes ou supérieures à l'architecture IPv4 actuelle.

Le réseau utilisateur final est un réseau terminal (stub network). La figure 1 illustre la topologie modèle pour le réseau utilisateur final.

                   +-------+-------+                      \
| Service | \
| Provider | | Service
| Router | | Provider
+-------+-------+ | Network
| /
| Customer /
| Internet Connection /
|
+------+--------+ \
| IPv6 | \
| Customer Edge | \
| Router | /
+---+-------+-+-+ /
Network A | | Network B | End-User
---+-------------+----+- --+--+-------------+--- | Network(s)
| | | | \
+----+-----+ +-----+----+ +----+-----+ +-----+----+ \
|IPv6 Host | |IPv6 Host | | IPv6 Host| |IPv6 Host | /
| | | | | | | | /
+----------+ +-----+----+ +----------+ +----------+ /

Figure 1: An Example of a Typical End-User Network

Cette architecture décrit :

  • Les capacités de base d'un routeur CE IPv6
  • Le provisionnement de l'interface WAN se connectant au fournisseur de services
  • Le provisionnement des interfaces LAN

Pour le trafic de multidiffusion IPv6, le routeur CE IPv6 peut agir comme un proxy MLD (Multicast Listener Discovery - Découverte d'auditeur de multidiffusion) [RFC4605] et peut prendre en charge un protocole de routage de multidiffusion dynamique.

Le routeur CE IPv6 peut être configuré manuellement dans une topologie arbitraire avec un protocole de routage dynamique. Le provisionnement et la configuration automatiques sont décrits pour un seul routeur CE IPv6 uniquement.

3.2.1. Communication locale​

Les adresses IPv6 locales au lien (link-local) sont utilisées par les hôtes communiquant sur un seul lien. Les adresses locales uniques IPv6 (ULA - Unique Local IPv6 Unicast Addresses) [RFC4193] sont utilisées par les hôtes communiquant au sein du réseau utilisateur final à travers plusieurs liens, mais sans exiger que l'application utilise une adresse globalement routable. Le routeur CE IPv6 agit par défaut comme point de démarcation entre deux réseaux en fournissant une limite ULA, une limite de zone de multidiffusion et des filtres de trafic d'entrée et de sortie.

Au moment de la rédaction de ce document, plusieurs implémentations d'hôtes ne gèrent pas le cas où elles ont une adresse IPv6 configurée et aucune connectivité IPv6, soit parce que l'adresse elle-même a une portée topologique limitée (par exemple, ULA), soit parce que le routeur CE IPv6 n'est pas connecté au réseau IPv6 sur son interface WAN. Pour prendre en charge les implémentations d'hôtes qui ne gèrent pas le multihoming dans un environnement multi-préfixe [MULTIHOMING-WITHOUT-NAT], le routeur CE IPv6 ne devrait pas, comme détaillé dans les exigences ci-dessous, s'annoncer comme un routeur par défaut sur la ou les interfaces LAN lorsqu'il n'a pas de connectivité IPv6 sur l'interface WAN ou lorsqu'il n'est pas provisionné avec des adresses IPv6. Pour la communication IPv6 locale, les mécanismes spécifiés dans [RFC4191] sont utilisés.

L'adressage ULA est utile lorsque le routeur CE IPv6 a plusieurs interfaces LAN avec des hôtes qui doivent communiquer entre eux. Si le routeur CE IPv6 n'a qu'une seule interface LAN (lien IPv6), alors l'adressage local au lien peut être utilisé à la place.

La coexistence avec IPv4 nécessite que tout routeur(s) CE IPv6 sur le LAN se conforme à ces recommandations, en particulier les exigences ULA-5 et L-4 ci-dessous.