3. Architektur
Dieser Abschnitt beschreibt das Architekturmodell für IPv6-Kundenrandrouter und vergleicht es mit der aktuellen IPv4-Architektur.
3.1. Aktuelle IPv4-Endbenutzer-Netzwerkarchitektur
Ein Endbenutzernetzwerk wird wahrscheinlich sowohl IPv4 als auch IPv6 unterstützen. Es wird nicht erwartet, dass ein Endbenutzer seine bestehende Netzwerktopologie mit der Einführung von IPv6 ändert. Es gibt einige Unterschiede in der Funktionsweise und Bereitstellung von IPv6; diese Unterschiede haben Auswirkungen auf die Netzwerkarchitektur. Ein typisches IPv4-Endbenutzernetzwerk besteht aus einem "Plug-and-Play"-Router mit NAT-Funktionalität und einer einzelnen Verbindung dahinter, die mit dem Dienstanbieternetzwerk verbunden ist.
Eine typische IPv4-NAT-Bereitstellung blockiert standardmäßig alle eingehenden Verbindungen. Das Öffnen von Ports ist typischerweise über ein Universal Plug and Play Internet Gateway Device (UPnP IGD) [UPnP-IGD] oder ein anderes Firewall-Steuerungsprotokoll erlaubt.
Eine weitere Konsequenz der Verwendung von privatem Adressraum im Endbenutzernetzwerk ist, dass es stabile Adressierung bietet; das heißt, sie ändert sich nie, selbst wenn Sie den Dienstanbieter wechseln, und die Adressen sind immer vorhanden, auch wenn die WAN-Schnittstelle ausgefallen ist oder der Kundenrandrouter noch nicht bereitgestellt wurde.
Viele vorhandene Router unterstützen dynamisches Routing (das Routen von anderen Routern lernt), und fortgeschrittene Endbenutzer können beliebige, komplexe Netzwerke durch manuelle Konfiguration von Adresspräfixen in Kombination mit einem dynamischen Routing-Protokoll aufbauen.
3.2. IPv6-Endbenutzer-Netzwerkarchitektur
Die Endbenutzer-Netzwerkarchitektur für IPv6 sollte gleichwertige oder bessere Fähigkeiten und Funktionalität als die aktuelle IPv4-Architektur bieten.
Das Endbenutzernetzwerk ist ein Stub-Netzwerk. Abbildung 1 illustriert die Modelltopologie für das Endbenutzernetzwerk.
+-------+-------+ \
| Service | \
| Provider | | Service
| Router | | Provider
+-------+-------+ | Network
| /
| Customer /
| Internet Connection /
|
+------+--------+ \
| IPv6 | \
| Customer Edge | \
| Router | /
+---+-------+-+-+ /
Network A | | Network B | End-User
---+-------------+----+- --+--+-------------+--- | Network(s)
| | | | \
+----+-----+ +-----+----+ +----+-----+ +-----+----+ \
|IPv6 Host | |IPv6 Host | | IPv6 Host| |IPv6 Host | /
| | | | | | | | /
+----------+ +-----+----+ +----------+ +----------+ /
Abbildung 1: Ein Beispiel eines typischen Endbenutzernetzwerks
Diese Architektur beschreibt:
- Grundlegende Fähigkeiten eines IPv6-CE-Routers
- Bereitstellung der WAN-Schnittstelle, die mit dem Dienstanbieter verbunden ist
- Bereitstellung der LAN-Schnittstellen
Für IPv6-Multicast-Verkehr kann der IPv6-CE-Router als Multicast Listener Discovery (MLD) Proxy [RFC4605] fungieren und kann ein dynamisches Multicast-Routing-Protokoll unterstützen.
Der IPv6-CE-Router kann manuell in einer beliebigen Topologie mit einem dynamischen Routing-Protokoll konfiguriert werden. Automatische Bereitstellung und Konfiguration werden nur für einen einzelnen IPv6-CE-Router beschrieben.
3.2.1. Lokale Kommunikation
Link-lokale IPv6-Adressen werden von Hosts verwendet, die auf einer einzelnen Verbindung kommunizieren. Unique Local IPv6 Unicast Addresses (ULAs) [RFC4193] werden von Hosts verwendet, die innerhalb des Endbenutzernetzwerks über mehrere Verbindungen hinweg kommunizieren, aber ohne dass die Anwendung eine global routbare Adresse verwenden muss. Der IPv6-CE-Router fungiert standardmäßig als Abgrenzungspunkt zwischen zwei Netzwerken, indem er eine ULA-Grenze, eine Multicast-Zonengrenze und Ingress- und Egress-Verkehrsfilter bereitstellt.
Zum Zeitpunkt der Erstellung dieses Dokuments behandeln mehrere Host-Implementierungen nicht den Fall, in dem sie eine konfigurierte IPv6-Adresse haben und keine IPv6-Konnektivität, entweder weil die Adresse selbst eine begrenzte topologische Erreichbarkeit hat (z. B. ULA) oder weil der IPv6-CE-Router nicht mit dem IPv6-Netzwerk auf seiner WAN-Schnittstelle verbunden ist. Um Host-Implementierungen zu unterstützen, die Multihoming in einer Multi-Präfix-Umgebung nicht behandeln [MULTIHOMING-WITHOUT-NAT], sollte der IPv6-CE-Router sich nicht, wie in den nachfolgenden Anforderungen detailliert beschrieben, als Standard-Router auf den LAN-Schnittstellen ankündigen, wenn er keine IPv6-Konnektivität auf der WAN-Schnittstelle hat oder wenn er nicht mit IPv6-Adressen bereitgestellt ist. Für lokale IPv6-Kommunikation werden die in [RFC4191] spezifizierten Mechanismen verwendet.
ULA-Adressierung ist nützlich, wenn der IPv6-CE-Router mehrere LAN-Schnittstellen mit Hosts hat, die miteinander kommunizieren müssen. Wenn der IPv6-CE-Router nur eine einzelne LAN-Schnittstelle (IPv6-Verbindung) hat, kann stattdessen link-lokale Adressierung verwendet werden.
Die Koexistenz mit IPv4 erfordert, dass alle IPv6-CE-Router im LAN diesen Empfehlungen entsprechen, insbesondere den Anforderungen ULA-5 und L-4 unten.