メインコンテンツまでスキップ

3. アーキテクチャ

本セクションでは、IPv6カスタマーエッジルーターのアーキテクチャモデルについて説明し、現在のIPv4アーキテクチャと比較します。

3.1. 現在のIPv4エンドユーザーネットワークアーキテクチャ​

エンドユーザーネットワークは、IPv4とIPv6の両方をサポートする可能性があります。エンドユーザーがIPv6の導入に伴って既存のネットワークトポロジーを変更することは期待されていません。IPv6の動作とプロビジョニングの方法にはいくつかの違いがあります。これらの違いは、ネットワークアーキテクチャに影響を与えます。典型的なIPv4エンドユーザーネットワークは、NAT機能を備えた「プラグアンドプレイ」ルーターと、その背後の単一のリンクで構成され、サービスプロバイダーネットワークに接続されています。

典型的なIPv4 NAT展開は、デフォルトですべての着信接続をブロックします。ポートの開放は、通常、Universal Plug and Play Internet Gateway Device (UPnP IGD) [UPnP-IGD] または他のファイアウォール制御プロトコルを使用して許可されます。

エンドユーザーネットワークでプライベートアドレス空間を使用することのもう1つの結果は、安定したアドレス指定を提供することです。つまり、サービスプロバイダーを変更してもアドレスは決して変わらず、WANインターフェースがダウンしている場合やカスタマーエッジルーターがまだプロビジョニングされていない場合でも、アドレスは常に存在します。

多くの既存のルーターは動的ルーティング (他のルーターからルートを学習する) をサポートしており、上級エンドユーザーは、アドレスプレフィックスの手動構成と動的ルーティングプロトコルを組み合わせて、任意の複雑なネットワークを構築できます。

3.2. IPv6エンドユーザーネットワークアーキテクチャ​

IPv6のエンドユーザーネットワークアーキテクチャは、現在のIPv4アーキテクチャと同等またはそれ以上の機能と機能性を提供する必要があります。

エンドユーザーネットワークはスタブネットワークです。図1は、エンドユーザーネットワークのモデルトポロジーを示しています。

                   +-------+-------+                      \
| Service | \
| Provider | | Service
| Router | | Provider
+-------+-------+ | Network
| /
| Customer /
| Internet Connection /
|
+------+--------+ \
| IPv6 | \
| Customer Edge | \
| Router | /
+---+-------+-+-+ /
Network A | | Network B | End-User
---+-------------+----+- --+--+-------------+--- | Network(s)
| | | | \
+----+-----+ +-----+----+ +----+-----+ +-----+----+ \
|IPv6 Host | |IPv6 Host | | IPv6 Host| |IPv6 Host | /
| | | | | | | | /
+----------+ +-----+----+ +----------+ +----------+ /

Figure 1: An Example of a Typical End-User Network
図1: 典型的なエンドユーザーネットワークの例

このアーキテクチャは、以下を記述します:

  • IPv6 CEルーターの基本機能
  • サービスプロバイダーに接続するWANインターフェースのプロビジョニング
  • LANインターフェースのプロビジョニング

IPv6マルチキャストトラフィックについて、IPv6 CEルーターはMulticast Listener Discovery (MLD) proxy (マルチキャストリスナー検出プロキシ) [RFC4605] として動作し、動的マルチキャストルーティングプロトコルをサポートする場合があります。

IPv6 CEルーターは、動的ルーティングプロトコルを使用して任意のトポロジーで手動構成できます。自動プロビジョニングと構成は、単一のIPv6 CEルーターについてのみ説明されています。

3.2.1. ローカル通信​

Link-local IPv6 addresses (リンクローカルIPv6アドレス) は、単一のリンク上で通信するホストによって使用されます。Unique Local IPv6 Unicast Addresses (ULAs) (ユニークローカルIPv6ユニキャストアドレス) [RFC4193] は、複数のリンクにわたってエンドユーザーネットワーク内で通信するホストによって使用されますが、アプリケーションがグローバルにルーティング可能なアドレスを使用する必要はありません。IPv6 CEルーターは、デフォルトで、ULA境界、マルチキャストゾーン境界、およびイングレスとイーグレスのトラフィックフィルターを提供することにより、2つのネットワーク間の境界点として機能します。

本文書の執筆時点では、いくつかのホスト実装は、IPv6アドレスが構成されているがIPv6接続がない場合を処理しません。これは、アドレス自体のトポロジー的な到達可能性が制限されている (例: ULA) か、IPv6 CEルーターがそのWANインターフェース上でIPv6ネットワークに接続されていないためです。マルチプレフィックス環境でのマルチホーミングを処理しないホスト実装 [MULTIHOMING-WITHOUT-NAT] をサポートするために、IPv6 CEルーターは、以下の要件で詳述されているように、WANインターフェース上でIPv6接続がない場合、またはIPv6アドレスでプロビジョニングされていない場合、LANインターフェース上でデフォルトルーターとして自分自身をアドバタイズすべきではありません (SHOULD NOT)。ローカルIPv6通信の場合、[RFC4191] で規定されているメカニズムが使用されます。

ULAアドレッシングは、IPv6 CEルーターが相互に通信する必要があるホストを持つ複数のLANインターフェースを持つ場合に有用です。IPv6 CEルーターが単一のLANインターフェース (IPv6リンク) のみを持つ場合、代わりにリンクローカルアドレッシングを使用できます。

IPv4との共存には、LAN上のすべてのIPv6 CEルーターがこれらの推奨事項、特に以下の要件ULA-5とL-4に準拠する必要があります。