Aller au contenu principal

RFC 5681 - TCP Congestion Control

  • Statut : Draft Standard
  • Publié : September 2009
  • Stream : IETF
  • Remplace : RFC 2581
  • Mis à jour par : RFC 9438
  • Errata : Errata de la RFC Editor

Statut de ce mémo​

Ce document spécifie un protocole de la voie de normalisation Internet (standards track) à l'intention de la communauté Internet, et sollicite des discussions et des suggestions d'amélioration. Veuillez vous référer à l'édition courante des « Internet Official Protocol Standards » (STD 1) pour l'état de normalisation et le statut de ce protocole. La diffusion de ce mémo est illimitée.

Avis sur le droit d'auteur​

Copyright (c) 2009 IETF Trust et les personnes identifiées comme auteurs du document. Tous droits réservés.

Ce document est soumis au BCP 78 et aux dispositions légales de l'IETF Trust relatives aux documents de l'IETF en vigueur à la date de publication de ce document (http://trustee.ietf.org/license-info). Veuillez examiner ces documents attentivement, car ils décrivent vos droits et restrictions concernant ce document.

Ce document peut contenir des éléments provenant de documents ou de contributions de l'IETF publiés ou rendus publics avant le 10 novembre 2008. Les personnes détenant les droits d'auteur sur certains de ces éléments peuvent ne pas avoir accordé à l'IETF Trust le droit d'autoriser des modifications de ces éléments en dehors du processus de normalisation de l'IETF. Sans obtention d'une licence adéquate auprès des détenteurs de ces droits, ce document ne peut être modifié en dehors du processus de normalisation de l'IETF, et aucune œuvre dérivée ne peut en être créée en dehors de ce processus, sauf pour le formatage en vue de sa publication en tant que RFC ou pour sa traduction dans des langues autres que l'anglais.

Résumé​

Ce document définit les quatre algorithmes de contrôle de congestion TCP interconnectés: démarrage lent (Slow Start), évitement de congestion (Congestion Avoidance), retransmission rapide (Fast Retransmit) et récupération rapide (Fast Recovery). En outre, le document spécifie comment TCP doit commencer la transmission après une période d'inactivité relativement longue, ainsi que la discussion de diverses méthodes de génération d'accusés de réception. Ce document rend obsolète le RFC 2581.

Table des matières​

Adresses des auteurs​

Mark Allman International Computer Science Institute (ICSI) 1947 Center Street Suite 600 Berkeley, CA 94704-1198 Phone: +1 440 235 1792 EMail: [email protected] http://www.icir.org/mallman/ Vern Paxson International Computer Science Institute (ICSI) 1947 Center Street Suite 600 Berkeley, CA 94704-1198 Phone: +1 510/642-4274 x302 EMail: [email protected] http://www.icir.org/vern/ Ethan Blanton Purdue University Computer Sciences 305 North University Street West Lafayette, IN 47907 EMail: [email protected] http://www.cs.purdue.edu/homes/eblanton/