RFC 5681 - TCP Congestion Control
- ステータス: Draft Standard
- 発行日: September 2009
- ストリーム: IETF
- 廃止: RFC 2581
- 更新: RFC 9438
- エラッタ: RFC Editor エラッタ
このメモの位置付け
本文書は、インターネットコミュニティのためのインターネット標準化トラックプロトコルを規定し、改善のための議論と提案を求めます。本プロトコルの標準化状態とステータスについては、"Internet Official Protocol Standards" (STD 1) の最新版を参照してください。本メモの配布は無制限です。
著作権表示
Copyright (c) 2009 IETF Trust および文書の著者として特定された人物。全著作権所有。
本文書は、BCP 78 および本文書の公開日に有効な IETF 文書に関する IETF Trust の法的条項 (http://trustee.ietf.org/license-info) の対象となります。これらの文書は本文書に関するあなたの権利と制限を記述しているため、注意深く確認してください。
本文書には、2008 年 11 月 10 日より前に公開または公に入手可能となった IETF 文書または IETF 投稿からの資料が含まれている場合があります。このような資料の一部の著作権を管理する人物は、IETF 標準化プロセス外での当該資料の改変を許可する権利を IETF Trust に付与していない可能性があります。そのような資料の著作権を管理する人物から適切なライセンスを取得しない限り、本文書は IETF 標準化プロセス外で改変できず、またその派生物を IETF 標準化プロセス外で作成することはできません。ただし、RFC として公開するための整形または英語以外の言語への翻訳は除きます。
概要
この文書は、TCPの4つの相互関連する輻輳制御アルゴリズムを定義します: スロースタート (Slow Start)、輻輳回避 (Congestion Avoidance)、高速再送信 (Fast Retransmit)、および高速回復 (Fast Recovery)。さらに、この文書は、比較的長いアイドル期間の後にTCPがどのように送信を開始すべきか、および様々な確認応答生成方法について規定しています。この文書はRFC 2581を廃止します。
目次
- 1. はじめに
- 2. 定義
- 3. 輻輳制御アルゴリズム
- 3.1. スロースタートと輻輳回避
- 3.2. 高速再送信/高速回復
- 4. 追加の考慮事項
- 4.1. アイドル接続の再起動
- 4.2. 確認応答の生成
- 4.3. 損失回復メカニズム
- 5. セキュリティに関する考慮事項
- 6. RFC 2001とRFC 2581間の変更
- 7. RFC 2581 からの変更点
- 8. 謝辞
- 9. 参考文献
著者のアドレス
Mark Allman International Computer Science Institute (ICSI) 1947 Center Street Suite 600 Berkeley, CA 94704-1198 Phone: +1 440 235 1792 EMail: [email protected] http://www.icir.org/mallman/ Vern Paxson International Computer Science Institute (ICSI) 1947 Center Street Suite 600 Berkeley, CA 94704-1198 Phone: +1 510/642-4274 x302 EMail: [email protected] http://www.icir.org/vern/ Ethan Blanton Purdue University Computer Sciences 305 North University Street West Lafayette, IN 47907 EMail: [email protected] http://www.cs.purdue.edu/homes/eblanton/