跳到主要内容

RFC 5681 - TCP Congestion Control

  • 状态: Draft Standard
  • 发布日期: September 2009
  • Stream: IETF
  • 废弃了: RFC 2581
  • 被更新: RFC 9438
  • 勘误: RFC Editor 勘误

本备忘录的状态​

本文档为互联网社区规定了一项互联网标准跟踪协议, 并请求讨论与改进建议. 请参考 "Internet Official Protocol Standards" (STD 1) 的当前版本, 以了解本协议的标准化状态和现状. 本备忘录的分发不受限制.

版权声明​

Copyright (c) 2009 IETF Trust 与文中标识为文档作者的人员. 保留所有权利.

本文档受 BCP 78 以及 IETF Trust 在本文件发布之日有效的与 IETF 文档相关的法律条款 (http://trustee.ietf.org/license-info) 约束. 请仔细审阅这些文档, 因其描述了您对本文件的权利与限制.

本文档可能包含 2008 年 11 月 10 日之前发布或公开的 IETF 文档或 IETF 投稿中的材料. 对这些材料中某些部分拥有版权的人可能未授予 IETF Trust 允许在 IETF 标准流程之外修改此类材料的权利. 在未从此类材料的版权控制方获得适当许可的情况下, 不得在 IETF 标准流程之外修改本文档, 也不得在 IETF 标准流程之外创建其衍生作品, 但为作为 RFC 发布而进行格式化或将其翻译为英语以外的语言除外.

摘要​

本文档定义了 TCP 的四个相互交织的拥塞控制算法: slow start、congestion avoidance、fast retransmit 和 fast recovery. 此外, 本文档规定了 TCP 在经历相对较长的空闲期之后应如何开始传输, 并讨论了各种确认生成方法. 本文档废弃了 RFC 2581.

目录​

作者地址​

Mark Allman International Computer Science Institute (ICSI) 1947 Center Street Suite 600 Berkeley, CA 94704-1198 Phone: +1 440 235 1792 EMail: [email protected] http://www.icir.org/mallman/ Vern Paxson International Computer Science Institute (ICSI) 1947 Center Street Suite 600 Berkeley, CA 94704-1198 Phone: +1 510/642-4274 x302 EMail: [email protected] http://www.icir.org/vern/ Ethan Blanton Purdue University Computer Sciences 305 North University Street West Lafayette, IN 47907 EMail: [email protected] http://www.cs.purdue.edu/homes/eblanton/