1. Einleitung
Internet-E-Mail unterscheidet eine Nachricht von ihrem Transport und teilt eine Nachricht weiter in einen Header und einen Body auf [RFC5322]. Die Header-Feldwerte von Internet-E-Mail enthalten verschiedene Zeichenketten, die für Benutzer sichtbar sein sollen. Der Bereich der unterstützten Zeichen für diese Zeichenketten war ursprünglich auf [ASCII] in 7-Bit-Form beschränkt. MIME [RFC2045] [RFC2046] [RFC2047] bietet die Möglichkeit, zusätzliche Zeichensätze zu verwenden, doch diese Unterstützung ist auf Body-Teil-Daten und auf spezielle Encoded-Word-Konstrukte beschränkt, die nur an einer begrenzten Anzahl von Stellen in Header-Feldwerten erlaubt waren.
Die Globalisierung des Internet erfordert die Unterstützung der weitaus größeren Zeichenmenge, die Unicode [RFC5198] bereitstellt, sowohl in E-Mail-Adressen als auch in den meisten Header-Feldwerten. Darüber hinaus führen komplexe Kodierungsschemata wie Encoded-Words zu Ineffizienzen sowie zu erheblichen Gelegenheiten für Verarbeitungsfehler. Und schließlich ist native Unterstützung für den UTF-8-Zeichensatz heute auf den meisten Systemen verfügbar. Daher ist es sehr wünschenswert, dass Internet-E-Mail UTF-8 [RFC3629] direkt unterstützt.
Dieses Dokument spezifiziert eine Erweiterung des Internet Message Format [RFC5322] und von MIME, die die direkte Verwendung von UTF-8 statt nur ASCII in Header-Feldwerten einschließlich E-Mail-Adressen erlaubt. Für Nachrichten, die dieses erweiterte Format verwenden, wird ein neuer Medientyp message/global definiert. Diese Spezifikation hebt außerdem die MIME-Beschränkung auf, die Nicht-Identity-Content-Transfer-Encodings bei jedem Untertyp des Top-Level-Typs message verbietet, damit message/global-Teile sicher über bestehende E-Mail-Infrastruktur übertragen werden können.
Diese Spezifikation basiert auf einem Modell nativer Ende-zu-Ende-Unterstützung für UTF-8, das von einer vom Transportsystem gewährleisteten "8-bit-clean"-Umgebung abhängt. Die Unterstützung der Beförderung über veraltete 7-Bit-Infrastruktur sowie der Verarbeitung durch 7-Bit-Empfänger erfordert zusätzliche Mechanismen, die von diesen Spezifikationen nicht bereitgestellt werden.
Diese Spezifikation ist eine Überarbeitung von [RFC5335] und ersetzt dieses. Abschnitt 6 von [RFC6530] beschreibt die Änderung des Ansatzes zwischen dieser Spezifikation und der vorherigen Version.