Zum Hauptinhalt springen

8. Normative Referenzen (Normative References)

Die folgenden Dokumente sind die normativen Grundlagen, die zur Implementierung von RFC 4511 erforderlich sind.

  • [RFC2119] Bradner, S., "Key words for use in RFCs to Indicate Requirement Levels", BCP 14, RFC 2119, March 1997.
    • Verwendung: Definiert die Auslegungsregeln normativer Schlüsselwörter wie MUST, SHOULD, MAY.
  • [RFC3629] Yergeau, F., "UTF-8, a transformation format of ISO 10646", STD 63, RFC 3629, November 2003.
    • Verwendung: Legt das UTF-8-Codierformat fest, von dem die LDAP-Zeichenkettenverarbeitung abhängt.
  • [RFC4510] Zeilenga, K., Ed., "Lightweight Directory Access Protocol (LDAP): Technical Specification Road Map", RFC 4510, June 2006.
    • Verwendung: Gibt die Roadmap und die Beziehungen der LDAP-Technikspezifikationen an.
  • [RFC4512] Zeilenga, K., "Lightweight Directory Access Protocol (LDAP): Directory Information Models", RFC 4512, June 2006.
    • Verwendung: Definiert das LDAP-Verzeichnisinformationsmodell, auf das Protokolloperationen verweisen.
  • [RFC4513] Harrison, R., Ed., "Lightweight Directory Access Protocol (LDAP): Authentication Methods and Security Mechanisms", RFC 4513, June 2006.
    • Verwendung: Definiert die LDAP-Authentifizierungsmethoden und Sicherheitsmechanismen.
  • [RFC4514] Zeilenga, K., Ed., "Lightweight Directory Access Protocol (LDAP): String Representation of Distinguished Names", RFC 4514, June 2006.
    • Verwendung: Definiert die Zeichenkettenrepräsentation des Distinguished Name (Distinguished Name).
  • [RFC4517] Legg, S., Ed., "Lightweight Directory Access Protocol (LDAP): Syntaxes and Matching Rules", RFC 4517, June 2006.
    • Verwendung: Definiert die LDAP-Syntaxen und Abgleichregeln (matching rules).
  • [RFC4520] Zeilenga, K., "Internet Assigned Numbers Authority (IANA) Considerations for the Lightweight Directory Access Protocol (LDAP)", BCP 64, RFC 4520, June 2006.
    • Verwendung: Legt die IANA-Registrierungs- und Zuteilungsaspekte im Zusammenhang mit LDAP fest.
  • [X.680] ITU-T Recommendation X.680, "Abstract Syntax Notation One (ASN.1): Specification of Basic Notation".
    • Verwendung: Definiert die ASN.1-Grundnotation, die die Darstellungsgrundlage des LDAP-ASN.1-Moduls bildet.
  • [X.690] ITU-T Recommendation X.690, "ASN.1 encoding rules: Specification of Basic Encoding Rules (BER), Canonical Encoding Rules (CER) and Distinguished Encoding Rules (DER)".
    • Verwendung: Definiert die BER-, CER- und DER-Codierregeln, von denen BER unmittelbar mit der LDAP-Protokollcodierung zusammenhängt.