Zum Hauptinhalt springen

Anhang C. Änderungen (Changes)

RFC 4511 ersetzt RFC 2251 und integriert die protokollbezogenen Inhalte der RFC 2830 und RFC 3771. Die wichtigsten Änderungen sind:

  • Die LDAPv3-Protokollspezifikation wurde in die RFC-4510-Technikspezifikationssammlung aufgenommen.
  • Die Anforderungen an die Behandlung von ASN.1-Erweiterbarkeit, dem BER-Codierteilset, den Protokolloperationen und den Kontrollelementen (control) wurden präzisiert.
  • Die StartTLS-Operation und die IntermediateResponse-Nachricht wurden in die Hauptprotokollspezifikation überführt.
  • Die Referenzen, Begriffe und IANA-Registrierungsregeln wurden aktualisiert, damit sie mit den begleitenden Dokumenten wie RFC 4512, RFC 4513, RFC 4517 und RFC 4520 übereinstimmen.
  • Mehrere Verhaltensweisen im Zusammenhang mit Fehlerbehandlung, referrals, Result-Codes und Verbindungszuständen wurden geklärt.

Diese Änderungen dienen vor allem der Konsolidierung der Spezifikation und der Klärung der Interoperabilität, mit dem Ziel, die Protokolldefinition von LDAPv3 konsistenter sowie leichter implementier- und erweiterbar zu machen.