RFC 4515 - Lightweight Directory Access Protocol (LDAP): Zeichenfolgendarstellung von Suchfiltern
- Status: Proposed Standard
- Veröffentlicht: June 2006
- Stream: IETF
- Ersetzt: RFC2254
- Errata: Keine Errata
Zusammenfassung
Lightweight Directory Access Protocol (LDAP)-Suchfilter werden im LDAP-Protokoll unter Verwendung einer binären Darstellung übertragen, die für die Verwendung im Netzwerk geeignet ist. Dieses Dokument definiert eine menschenlesbare Zeichenfolgendarstellung von LDAP-Suchfiltern, die für die Verwendung in LDAP-URLs (RFC 4516) und in anderen Anwendungen geeignet ist.
Inhaltsverzeichnis
- 1. Einleitung
- 2. Definition des LDAP-Suchfilters
- 3. Definition des Zeichenfolgen-Suchfilters
- 4. Beispiele
- 5. Sicherheitsüberlegungen
- 6. Normative Verweise
- 7. Informative Verweise
- 8. Danksagungen
- Anhang A. Änderungen seit RFC 2254 (Appendix A. Changes Since RFC 2254)
Anschriften der Autoren
Mark Smith, Editor
Pearl Crescent, LLC
447 Marlpool Dr.
Saline, MI 48176
USA
Phone: +1 734 944-2856
EMail: [email protected]
Tim Howes
Opsware, Inc.
599 N. Mathilda Ave.
Sunnyvale, CA 94085
USA
Phone: +1 408 744-7509
EMail: [email protected]
Vollständige Urheberrechtserklärung
Copyright (C) The Internet Society (2006).
Dieses Dokument unterliegt den in BCP 78 festgelegten Rechten, Lizenzen und Einschränkungen, und die Autoren behalten alle ihre Rechte vor, sofern nicht ausdrücklich etwas anderes bestimmt ist.
Dieses Dokument und die darin enthaltenen Informationen werden „wie besehen“ bereitgestellt. Die Beitragenden, die Organisation, die sie vertreten oder fördert (falls zutreffend), die Internet Society und die Internet Engineering Task Force übernehmen keinerlei ausdrückliche oder stillschweigende Gewährleistung, einschließlich, ohne Einschränkung, jeglicher Gewährleistung, dass die Nutzung der Informationen in diesem Dokument keine Rechte verletzt, oder stillschweigender Gewährleistungen der Marktgängigkeit oder Eignung für einen bestimmten Zweck.
Geistiges Eigentum
Die IETF nimmt keine Stellung zur Gültigkeit oder zum Umfang irgendwelcher Rechte an geistigem Eigentum oder anderer Rechte, die im Zusammenhang mit der Implementierung oder Nutzung der in diesem Dokument beschriebenen Technologie geltend gemacht werden, und gibt keine Erklärung ab, dass sie unabhängige Anstrengungen unternommen hätte, um solche Rechte zu identifizieren. Das Verfahren zum Umgang mit Rechten in Bezug auf RFC-Dokumente finden Sie in BCP 78 und BCP 79.
Kopien von Offenlegungen geistigen Eigentums, die dem IETF-Sekretariat vorgelegt wurden, jeglicher Zusicherung erteilter Lizenzen oder der Ergebnisse von Implementierern, die eine allgemeine Lizenz oder Genehmigung zur Nutzung solcher ausschließlichen Rechte anstreben, sind im Online-Repository für geistiges Eigentum der IETF unter http://www.ietf.org/ipr verfügbar.
Die IETF lädt alle betroffenen Parteien ein, sie auf Urheberrechte, Patente oder Patentanmeldungen oder andere ausschließliche Rechte hinzuweisen, die die zur Implementierung dieses Standards erforderliche Technologie abdecken könnten. Bitte senden Sie entsprechende Informationen an [email protected].
Danksagungen
Die Finanzierung der RFC-Editor-Funktion wird durch die IETF Administrative Support Activity (IASA) bereitgestellt.