Anhang A. DNSSEC-Algorithmen und Digest-Typen
Dieser Anhang führt die Einträge der Registries für DNS-Sicherheits-Algorithmusnummern (DNSSEC Algorithm Number) und DNSSEC-DS-Digest-Typen (DNSSEC DS Digest Type) zum Zeitpunkt der Abfassung dieses Dokuments auf. Bei jedem Eintrag ist sein Verwendungsstatus in DNSSEC angegeben (mandatory / zwingend, recommended / empfohlen, optional / optional oder not recommended / nicht empfohlen).
A.1. DNS-Sicherheits-Algorithmusnummern
| Nummer | Beschreibung | Verwendungsstatus in DNSSEC | Anmerkungen |
|---|---|---|---|
| 0 | Reserviert (Reserved) | — | Nicht zugewiesen |
| 1 | RSA/MD5 | Nicht empfohlen (NOT RECOMMENDED) | Siehe [RFC3110] |
| 2 | Diffie-Hellman | Optional (OPTIONAL) | Siehe [RFC2539] |
| 3 | DSA/SHA-1 | Optional (OPTIONAL) | Siehe [RFC2536] |
| 4 | Reserviert für ECC (Reserved) | Reserviert (Reserved) | — |
| 5 | RSA/SHA-1 | Empfohlen (RECOMMENDED) | Siehe [RFC3110] |
| 6 | DSA-NSEC3-SHA1 | Optional (OPTIONAL) | Siehe [RFC5157] |
| 7 | RSASHA1-NSEC3-SHA1 | Empfohlen (RECOMMENDED) | Siehe [RFC5157] |
| 8 | Reserviert für RSASHA256 (Reserved) | Reserviert (Reserved) | — |
| 9 | RSASHA256 | Empfohlen (RECOMMENDED) | Siehe [RFC5702] |
| 10 | RSASHA512 | Optional (OPTIONAL) | Siehe [RFC5702] |
| 11 | Reserviert für ECC-GOST (Reserved) | Reserviert (Reserved) | — |
| 12 | ECC-GOST | Optional (OPTIONAL) | Siehe [RFC5933] |
| 13 | ECDSAP256-SHA256 | Empfohlen (RECOMMENDED) | Siehe [RFC6605] |
| 14 | ECDSAP384-SHA384 | Empfohlen (RECOMMENDED) | Siehe [RFC6605] |
| 15-251 | Nicht zugewiesen (Unassigned) | — | Durch IETF-Standardaktion (Standards Action) zugewiesen |
| 252 | Indirect | Optional (OPTIONAL) | Siehe [RFC4034] Abschnitt 2 |
| 253 | Privater Schlüssel (Private [explicit]) | Optional (OPTIONAL) | Siehe [RFC4034] Abschnitt 2 |
| 254 | Privater Schlüssel (Private [OID]) | Optional (OPTIONAL) | Siehe [RFC4034] Abschnitt 2 |
| 255 | Reserviert (Reserved) | — | — |
Hinweis: Die Werte 8, 11 sowie die Werte im Bereich 15-251 waren zum Zeitpunkt der Abfassung reserviert oder nicht zugewiesen. Nachfolgende Spezifikationen (wie [RFC5702], [RFC5933], [RFC6605], [RFC5157]) haben einige dieser Werte zugewiesen. Um den Zustand zum Zeitpunkt der Abfassung getreu widerzuspiegeln, behält die obige Tabelle die im Originaltext genannten Reservierungen/Nichtzuweisungen bei.
A.2. DNSSEC-DS-Digest-Typen
| Nummer | Beschreibung | Verwendungsstatus in DNSSEC |
|---|---|---|
| 0 | Reserviert (Reserved) | — |
| 1 | SHA-1 | Empfohlen (RECOMMENDED) |
Abschnittsnavigation:
- Vorheriger: 10. Referenzen
- Nächster: Anhang B. Berechnung des Schlüsselkennzeichens