跳到主要内容

附录 B. 导入的 ABNF

以下核心规则通过引用纳入, 其定义见 [RFC5234] 附录 B.1: ALPHA (字母)、CR (回车)、CRLF (CR LF)、CTL (控制字符)、DIGIT (十进制 0-9)、DQUOTE (双引号)、HEXDIG (十六进制 0-9/A-F/a-f)、LF (换行)、OCTET (任意 8 位数据序列)、SP (空格) 和 VCHAR (任意可见 US-ASCII 字符).

以下规则定义在 [RFC7230] 中:

OWS           = <OWS, see [RFC7230], Section 3.2.3>
field-name = <field-name, see [RFC7230], Section 3.2>
quoted-string = <quoted-string, see [RFC7230], Section 3.2.6>
token = <token, see [RFC7230], Section 3.2.6>

port = <port, see [RFC7230], Section 2.7>
pseudonym = <pseudonym, see [RFC7230], Section 5.7.1>
uri-host = <uri-host, see [RFC7230], Section 2.7>

以下规则定义在其他部分:

HTTP-date     = <HTTP-date, see [RFC7231], Section 7.1.1.1>